Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Программирование циклов на Паскале.

5-9 класс

Покупатель должен заплатить в кассу S рублей. У него имеются монеты в 1, 2 и 5 рублей, а также купюры достоинством в 10, 50, 100 и 500 рублей (достаточное количество). Сколько монет и купюр разного достоинства отдаст покупатель, если он начинает платить с самых крупных?

Nastyacom6411 24 окт. 2014 г., 12:06:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Garovaa
24 окт. 2014 г., 12:57:11 (9 лет назад)

var 
  m1,m2,m5,m10,m50,m100,m500,s:integer;
begin 
m1:=0;
m2:=0; 
m5:=0; 
m10:=0; 
m50:=0; 
m100:=0; 
m500:=0; 
readln(s); 
while s>0 do 
begin   
if s>=500 then   
begin     
s:=s-500;     
m500:=m500+1;   
end   
else     
if s>=100 then     
begin       
s:=s-100;       
m100:=m100+1;     
end     
else       
if s>=50 then       
begin         
m50:=m50+1;         
s:=s-50;       
end       
else         
if s>=10 then         
begin           
s:=s-10;           
m10:=m10+1;         
end         
else           
if s>=5 then           
begin             
m5:=m5+1;             
s:=s-5;           
end           
else             
if s>=2 then             
begin               
m2:=m2+1;               
s:=s-2;             
end             
else             
begin               
m1:=m1+1;               
s:=s-1;             
end; 
end; 
writeln('500р = ',m500); 
writeln('100р = ',m100); 
writeln('50р = ',m50); 
writeln('10р = ',m10); 
writeln('5р = ',m5); 
writeln('2р = ',m2); 
writeln('1р = ',m1);
end.

Ответить

Другие вопросы из категории

1) x2 —> x8
Дам 40 баллов!!!

Представьте в виде графа основные элементы графического интерфейса компьютера.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

1)Как можно описать на Паскале 1)Как можно описать на Паскале массив,в котором будет храниться значения численности населения Москвы к концу

каждого года XX века?
2)Вы приобрели котёнка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будет храниться значения веса котёнка в течение месяца (например,мая)?

Запросить стороны треугольника и определить,является ли он разносторонним,равносторонним или равнобедренным. Учесть: третья сторона не должна превышать

сумму двух других,иначе треугольник не существует. Задача на тему "Программирование ветвлений на Паскале".



Вы находитесь на странице вопроса "Программирование циклов на Паскале.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.