Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПАСКАЛЬ: Найти все четырехзначные числа у которых сумма крайних цифр равна сумме средних цифр.

10-11 класс

Liza20001108 30 сент. 2016 г., 15:53:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КсенияЛиса123
30 сент. 2016 г., 16:55:26 (7 лет назад)

Банальный вариант

var i:integer;
begin
for i:=1000 to 9999 do
if i mod 10 + i div 1000 = i div 100 mod 10 + i div 10 mod 10
then writeln(i)
end. 

+ 0 -
Mixail200397
30 сент. 2016 г., 18:48:41 (7 лет назад)

Комментарий удален

+ 0 -
Ybrnj
30 сент. 2016 г., 21:38:08 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

1 и 2 пожалуйста очень надо
Вычислите сумму чисел x и y, при x = 1D16, y = 728.
Если число меньше делимого равно этому числу, то это число называется чудом.Опредите, что данное число N является чудо цифрой. Формат входных

данных.

На первой доржка входного файла дане одна целая цифра N (1‹=N‹=1000000 )

Формат выходных данных

Если цифра является чудом , ответьте "да" или "нет"

Дан файл содержащий текст (не менее 3 строк) сколько слов в тексте?

(программирование)

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Помогите пожалуйста!

1.С клавиатуры вводится целое двузначное число.Вывести на экран сумму его цифр.
2.Найти все двузначные числа,в которых есть цифра 4.
Прошу,помогите.

придумайте натуральное число, которое удовлетворяет следующим условиям:

1 запись числа состоит из семи цифр
2 сумма всех цифр равна 39

В городской олимпиаде по математике

по 5 и 6 классам приняли участие 59
детей. Каждому участнику
присваивается шифр - произвольное
число, оканчивающееся номером
класса, в котором он учится, оказалось,
что сумма шифров пятиклассников
равна сумме шифров шестиклассников.
На следующий год в олимпиаде по 6 и 7
классам приняли участие эти же 59
ребят. Могли ли суммы шифров этих
шестиклассников и семиклассников
оказаться равными? Ответ обоснуйте



Вы находитесь на странице вопроса "ПАСКАЛЬ: Найти все четырехзначные числа у которых сумма крайних цифр равна сумме средних цифр.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.