Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

вводится вещественное число А не пользуясь никакими арифметическими операциями кроме умножения получить А в 7 степени за четыре операции.

10-11 класс

M1266735 09 окт. 2013 г., 23:05:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SkixXx
09 окт. 2013 г., 23:43:37 (10 лет назад)

program g;
var A,B,C: real;
begin
readln(A);
 C:=A; // А в степени 1
 B:=A*A; // А в степени 2
 A:=B*B; // А в степени 4
 A:=A*B*C; // А в степени 1 на 2 на 4 = А в степени 7
writeln(A);
end.
 
 

+ 0 -
Vladik966
10 окт. 2013 г., 0:49:09 (10 лет назад)

Можно ли вводить дополнительные переменные? Писать на паскаль?

+ 0 -
Rcif02021999
10 окт. 2013 г., 2:23:53 (10 лет назад)

да это паскаль ,можно ))

Ответить

Другие вопросы из категории

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Дано

число а. Не пользуясь никакими другими арифметическими операциями, кроме
сложения, получить: 6а за три операции. Paskal

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.



Вы находитесь на странице вопроса "вводится вещественное число А не пользуясь никакими арифметическими операциями кроме умножения получить А в 7 степени за четыре операции.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.