Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

n-factorial это произведение всех чисел от 1 до N.для заданного числа N оппредилите сколько нулей в конце десятичной записи n-factorial.

5-9 класс

TERTESHNIKOVAN 10 нояб. 2014 г., 9:58:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kazanzevanatali
10 нояб. 2014 г., 11:00:45 (9 лет назад)

uses crt;
var i,n,ans,fact:integer;
flag:boolean;
begin
flag:=true;
read(n);
fact:=1;
for i:=2 to n do
fact:=fact*i;
while flag=true do
if fact mod 10=0 then
begin
ans:=ans+1;
fact:=fact div 10;
end
else
flag:=false;
writeln(ans);
end.

Ответить

Другие вопросы из категории

Запишите цифрами числа, встречающиеся в тексте: «Миллиард – очень большое число. За тридцать лет с первого января тысяча девятьсот семидесятого года по

тридцать первое декабря тысяча девятьсот девяносто девятого года прошло десять тысяч девятьсот пятьдесят семь суток, что составляет двести шестьдесят две тысячи девятьсот шестьдесят восемь часов или девятьсот сорок шесть миллионов шестьсот восемьдесят четыре тысячи восемьсот секунд. Значит, за тридцать лет не пройдёт и миллиарда секунд».

Читайте также

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!



Вы находитесь на странице вопроса "n-factorial это произведение всех чисел от 1 до N.для заданного числа N оппредилите сколько нулей в конце десятичной записи n-factorial.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.