Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать программу на языке Паскаль по-этому алгоритму

10-11 класс

Katykala 15 марта 2016 г., 20:08:32 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sierghieizimin
15 марта 2016 г., 21:44:06 (8 лет назад)

const
  n = 4;

var
  naim: array[1..n] of string;
  cena: array[1..n] of integer;
  i, plata, sda4a: integer;

begin
  naim[1] := 'Л.Толстой. Анна Каренина'; cena[1] := 130;
  naim[2] := 'В.Скотт. Айвенго'; cena[2] := 185;
  naim[3] := 'А.Белянин. Рыжий рыцарь'; cena[3] := 240;
  naim[4] := 'Р.Шеппард. Фотографу-пейзажисту'; cena[4] := 539;
  Writeln('*** Электронный киоск ***');
  for i := 1 to n do Writeln(i, '. ', naim[i], ',    ', cena[i], '=');
  Write('Укажите номер нужной книги, иное число - отказ -> ');
  Readln(i);
  if (i in [1..n]) then begin
    Write('Введите сумму оплаты -> ');
    Readln(plata);
    sda4a := plata - cena[i];
    if sda4a > 0 then
      Writeln('Благодарим за покупку! Заберите книгу и сдачу ', sda4a)
    else if sda4a < 0 then Writeln('Вам нужно добавить еще ', -sda4a)
    else Writeln('Благодарим за покупку! Заберите книгу.')
  end
  else Writeln('Приходите еще, возможно в следующий раз Вы что-то найдете')
end.

Тестовое решение:

*** Электронный киоск ***
1. Л.Толстой. Анна Каренина,    130=
2. В.Скотт. Айвенго,    185=
3. А.Белянин. Рыжий рыцарь,    240=
4. Р.Шеппард. Фотографу-пейзажисту,    539=
Укажите номер нужной книги, иное число - отказ -> 3
Введите сумму оплаты -> 500
Благодарим за покупку! Заберите книгу и сдачу 260


+ 0 -
Sergei895111
16 марта 2016 г., 0:19:38 (8 лет назад)

Плохо видно

Ответить

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

нужно написать программу на языке паскаль по условию:

Найти сумму элементов массива расположенных до последнего положительного элемента
Буду бескрайне благодарна, если поможете мне))

Задан вид квадратного уравнения ах квадрат +bx+c=0, коэффициенты a,b,c. Найти корни уравнения x1,x2.

1. Разработать схему алгоритма программы
2. Составить программу на языке Паскаль по разработанному алгоритму

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1



Вы находитесь на странице вопроса "Написать программу на языке Паскаль по-этому алгоритму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.