Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напистаь программу удаления из строки чётных или нечётных чисел

10-11 класс

Bboyworm 07 апр. 2015 г., 12:30:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lyalyuha
07 апр. 2015 г., 13:18:34 (9 лет назад)

 Для удаления чётных:

 

#include <stdio.h>
#include <stdlib.h>

int main()
{
int i = 0, n = 0, c = 0;
char input[50], output[50];

scanf("%s", input);

for(i = 0; i < strlen(input); i++)
{
if((input[i]-30)%2 != 0)
{
output[n] = input[i];
n++;
}
output[n] = NULL;
}
printf("%s", output);
return 0;
}

 

 

Для удаления нечётных:

 

#include <stdio.h>
#include <stdlib.h>

int main()
{
int i = 0, n = 0, c = 0;
char input[50], output[50];

scanf("%s", input);

for(i = 0; i < strlen(input); i++)
{
if((input[i]-30)%2 == 0)
{
output[n] = input[i];
n++;
}
output[n] = NULL;
}
printf("%s", output);
return 0;
}

Ответить

Другие вопросы из категории

вычислите произведение всех целых чисел, расположенных за минимальным значением.

нужна программа для open office
как объяснила мне препод: вводишь произвольное количество чисел(допустим 6 чисел), с помощью формулы "min" вычислить минимальное... и нужно перемножить все числа расположенные после этого минимального числа)
например: 2 3 0 6 7 8 min=0
и нужно по какой-то функции перемножить числа 6 7 8
и если 0 поставить в другое место, числа после 0 все также перемножались)

что такое флэш-память?

Читайте также

с клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и

последняя буквы слова

в)выводт на экран первый,второй и последний символы

г)определяет,чётно или нечётно количество символов в нём

Помогите написать в паскале!

Ввести три целых числа
x, y, z. Если хотя бы одно из них четное,

то
первому четному числу присвоить значение произведения этих чисел.



Сообразил только как определить чётное или нечётное число а как дальше не могу понять!


program Lab2;
var x,y,z: integer;
Begin

Writeln ('Введите число');
Readln (x);
if x mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (y);
if y mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (z);
if z mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');
end.








№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.



Вы находитесь на странице вопроса "Напистаь программу удаления из строки чётных или нечётных чисел", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.