Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

a) Составить процедуру

10-11 класс

вычисления чисел Фиббоначчи для i=1,2,..,n, если : F[1]=F[2]=1;F[i-2]+F[i-2],т.е F[3]=F[1]+F[2],F[4]=F[3]+F[2] и т.д . Использовать
процедуру для n=10,n=15.



Nastydemenok 03 февр. 2015 г., 20:48:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VladikLy4ec
03 февр. 2015 г., 21:20:08 (9 лет назад)

а) Procedure Fibbonachi(Const n: Integer);
Var i, a, b, t: Integer;
begin
    a := 1;
    b := 1;
    for i:=1 to n-1 do
        if i = 1 then Write(a, ', ')
        else if i = 2 then Write(b, ', ')
        else begin
            Write(a+b, ', ');
            t := a+b;
            a := b;
            b := t;
        end;
    WriteLn(a+b);
end;

begin
    Fibbonachi(15);
end.

Ответить

Другие вопросы из категории

Пожалуйста помогите

Надо составить логическое выражение по логической схеме

Можете помочь? Пожалуйста!

В концептуальную базу ОПП не входит:


1. модульность

2. иерархия

3. абстрагирование

4. инвариантность

5. инкапсуляция

для чего нужна видеопамять

Читайте также

С.Р.О.Ч.Н.О. Составить процедуру, вичисляющую значение TRUE, если в первом из двух заданных одномерных массивов количество

отрицательных элементов окажется больше, чем во втором, и значение FALSE в противном случае. Использовать такую процедуру для массивов: R = (0; 0.005; -0.02; -87.5; 50) W = (45; 721.5; 8.63; -76.97; 3)

C.Р.О.Ч.Н.О.

Составить процедуру для нахождения номера элемента наибольшего и наименьшего

элементов одномерного массива. Используя эту процедуру, поменять местами в строке
наибольший и наименьший элементы соответственно с первым и последним элементом
строки.

Помогите пожалуйста!!!СРОЧНО!!! Прошу!!!Написать программу в паскале!!!

Составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. Замена выполняется, начиная с заданной позиции строки.

Использовать список при следующем его описании: Type AdrCel=^Element;

Element=record
Info:integer;
Next:AdrCel;
End;

Составить процедуру, которая удаляет из списка второй элемент, если такой есть.


ХЭЛП МИ

Нерввы на пределе, завтра сдавать, а в процедуре организовать не получается... Составить программу для решения следующей задачи: Дана строка.

Зашифровать ее, переворачивая каждое слово. Создать процедуры для разбиения строки на слова и записи слова в обратном порядке.

Привет, Вася!

!ясаВ ,тевирП



Вы находитесь на странице вопроса "a) Составить процедуру", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.