Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задача на языке паскаль абс

10-11 класс

Дан одномерный массив, который содержит не более 60 символов, которые образуют слова, разделённые одним пробелом. Ответить на вопрос, есть ли среди этих слов данное слово.

Kumiko 26 авг. 2015 г., 23:17:58 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zae4ka
27 авг. 2015 г., 1:43:15 (8 лет назад)


const     n = 60;
 var c : array [1..n] of char; 
    a,s : string;
     r : boolean; 
    i : integer; 
 begin   
 
// Пропускаю формирование массива

    writeln ('введите искомое слово');  
 readln (a); 
  for i := 1 to n do    begin 
    if c[i] <> ' '  then 
     s := s + c[i]; 
   if (c[i] = ' ') or (i = n) then
       begin        writeln (s); 
        if a=s then     
           r := true;     
     s := '';     
         end;    
 end;  

   if r then 
 writeln ('есть')   
 else  
   writeln ('нет');
 end.

Ответить

Другие вопросы из категории

1.вычислить факториал N. (4!=1*2*3*4=24)

2.найти среднее геометрическое N чисел
3. вычислить сумму чисел кратных 6 из интервала от 5 до 100 включительно
в программе паскаль

1.Написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность.

2.Вставить число А перед всеми элементами, большими А, а число В - после всех элементов, меньших его.
3.Дана матрица Ф(6х7), заполненный случайным образом. Заменить максимальный элемент каждой строки на противоположный по знаку.
4. Дан двумерный массив. Найти сумму элементов его главной диагонали и поизведение элементов побочной диагонали. Результат занести в одномерный массив.
Пожалуйста, помогите, очень нужно! Хотя бы некоторые решите. Второй день не могу сделать! Тема одномерных и двумерных массивов.

Читайте также

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Помогите написать задачу на языке Паскаль:

Даны действительные числа a, b, c, d. Если a<b<c<d, то каждое число заменить наибольшим из них. Если a>b>c>d, то каждое число заменить средним арифметическим всех значений. В противном случае все числа заменяются своими квадратами



Вы находитесь на странице вопроса "Задача на языке паскаль абс", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.