Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова.

5-9 класс

Написать программу в Pascal.

RicHikon 20 марта 2017 г., 17:07:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
981324
20 марта 2017 г., 19:04:51 (7 лет назад)

var a,b,c:integer;
 p,n:string;
begin
readln(p)
;For a:=1 to length(p) do
begin
n:=copy(p,a,1);
If (n=' ') or (n=',') then
begin
If b>c then c:=b;
b:=0
end
else
b:=b+1;
end;
If c=0 then c:=b;
writeln (c);
end.

+ 0 -
Olgaantonov
20 марта 2017 г., 19:47:12 (7 лет назад)

как понять; что ввод закончен?

+ 0 -
Foxball
20 марта 2017 г., 20:57:05 (7 лет назад)

Больше ничего не дано(

Ответить

Другие вопросы из категории

Отметьте объекты классной комнаты:

рабочий стол
окно
папка
файл
компьютер

Как запустить графический редактор Paint
программа нахождения площади прямоуголника ,

программа нахождения площади круга
напишите пожалуйста,очень надо

Читайте также

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

ПОМОГИТЕ С ПРОГРАММОЙ. Язык #паскаль.

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими). Вывести строку, содержащую эти же слова, разделенные одним символом "."(точка). В конце строки точку не ставить.

все пятибуквенные слова составленные из латинских букв F,N,S ЗАПИСАНЫ В АЛФАВИТНОМ ПОРЯДКЕ

1.FFFFF
2.FFFFN
3.FFFFS
4FFFNF
5.........
.Определите слова которые будут идти в этом списке 7,27,90,101,196.Возможно вам будет проще ответить на третий и четвертый вопрос если вы будете знать,что на 99-ом месте в этом списке стоит строка NFNSS
в ОТВЕТЕ НУЖНО ЗАПИСАТЬ ПЯТЬ СТРОК СОСТОЯЩИХ ИЗ ЛАТИНСКИХ БУКВ.Ответ на каждое задание нужно писать в отдельной строке.(в 1 строке слово стоящее 7-ым,во 2-ой слово стоящее 27-ым,и далее 90,101 и 196 также)Порядок записи слов менять нельзя



Вы находитесь на странице вопроса "Дана строка, состоящая из слов, разделённая пробелами и запятыми, определить длину самого короткого и самого длинного слова.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.