Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дана квадратная матрица, заполненная случайными числами

5-9 класс

указать индексы всех элементов, имеющих наибольшее
значение.




Danchik22rus 27 янв. 2014 г., 0:09:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анюта003
27 янв. 2014 г., 0:41:14 (10 лет назад)

program gt;
var a:array[1..100,1..100]of integer;
n,i,max,,j:integer;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
a[i,j]:=random(100)-50;
max:=a[1,1];
for i:=1 to n do
begin
for j:=1 to n do
begin
if(a[i,j]>max)then max:=a[i,j];
end;
end;
for i:=1 to n do
begin
for j:=1 to n do
begin
if(a[i,j]=max)then writeln(i, ' ',j);
end;
end;
end.

Ответить

Другие вопросы из категории

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.



Вы находитесь на странице вопроса "дана квадратная матрица, заполненная случайными числами", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.