Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить пожалуйста! на с++ Часы :

5-9 класс

С начала суток прошло H часов, M минут, S секунд (0<=H<12, 0<=M<60, 0<=S<60). По
данным числам H, M, S определите угол (в градусах), на который повернулаcь часовая
стрелка с начала суток и выведите его в виде действительного числа.
(При решении этой задачи нельзя пользоваться условными инструкциями и циклами.)

пример:

Ввод: 1 2 6

Вывод: 31.05

Сашуня1564 25 нояб. 2015 г., 10:28:33 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Наталья1979
25 нояб. 2015 г., 13:28:03 (8 лет назад)

#include <iostream>

using namespace std;

main() {
double rad,k;
cin>>k;
rad=(3600*k);
cin>>k;
rad=rad+(60*k);
cin>>k;
rad=rad+k;
while (rad>=43200) {
rad=rad-43200;
}
rad=rad/120;
cout<<rad;
}

Ответить

Другие вопросы из категории

Помогите составить программу по Паскаль АВС для решения уравнения. программа с функциями что ли

5х^2-4х/х^3, х>0
5х^2-4х/х, х=0
5х^2-4х, х<0
это система. заранее благодарна тому, кто сможет мне помочь)счастья тебе

Срочно помагите

примеры материальных и абстрактных моделей для объекта дом

В какой четверти принадлежит точка с координатой(х:у) ?

На входе подаются 2 члена(х:у)
На выходе название четверти

Читайте также

Помогите решить пожалуйста, если можно то блок-схемой:) Одна тетенька произносит К слов в минуту, другая тетенька С слов в минуту. Кто и на

сколько больше скажет слов за три часа если они разговаривают одновременно не слушая друг друга.

Помогите решить пожалуйста !!!Пользователь работал с каталогом C:\Учеба\Математика\Задания. Сначала он поднялся на один уровень вверх, затем еще раз

поднялся на один уровень вверх и после этого спустился в каталог Биология, далее спустился в каталог Оценки. Запишите полный путь каталога, в котором оказался пользователь.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.



Вы находитесь на странице вопроса "Помогите решить пожалуйста! на с++ Часы :", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.