Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

помогите пожалуйста

5-9 класс

Neo920 25 янв. 2014 г., 12:59:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лобзи
25 янв. 2014 г., 13:39:44 (10 лет назад)

s=5   если надо, могу обосновать. Только скажи :)

Смотри, а = 23
p=a ( то есть p=23)
s=0

начало цикла этот цикл называет "пока" то есть у нас условие: Пока (Р больше 0), мы делаем: 
s присваиваем s + p и записываем остаток от деления ( то есть 0заменяем на (0+23)/10
23 - остаток 3, теперь s=3)
а переменной p присваиваем p делим на 10 и записываем ответ без остатка ( то есть 23 делим на 10, получаем 2, теперь p=2

Тут у нас цикл закончился, смотрим p больше 0? (2 больше 0?) да, значит повторяем
s присваиваем s + p и записываем остаток от деления ( то есть 3заменяем на (3+2)/10
5 - остаток 5, теперь s=5)
а переменной p присваиваем ( p делим на 10 и записываем ответ без остатка ( то есть 2 делим на 10, получаем 0, теперь p=0 )
 Цикл опять закончился. Проверяем p больше 0? (0 больше 0?) нет, 0 не больше 0 т.к. 0 равен 0.
Значит выходим из цикла, получились переменные
p=0
s=5

+ 0 -
Прималинка
25 янв. 2014 г., 15:05:49 (10 лет назад)

с полным решением? или если напишу ответы ты поймёшь

+ 0 -
1SUHOI
25 янв. 2014 г., 16:38:20 (10 лет назад)

мне только 190 номер пожалуйста, там где а=23

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.