Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить блок-схемы и программы на Паскале для решении задач: компьютер запрашивает номер дня недели, после ввода компьютер сообщает название

10-11 класс

этого дня.например, если ввели 1, то выдается фаза <> и т.д

Nataxa10 29 июня 2015 г., 23:46:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrRock100
30 июня 2015 г., 1:07:39 (8 лет назад)

program Week;
var day:integer; week:array[1..7] of string;
begin
  week[7]:='Воскресенье';
  week[6]:='Суббота';
  week[5]:='Пятница';
  week[4]:='Четверг';
  week[3]:='Среда';
  week[2]:='Вторник';
  week[1]:='Понедельник';
  write('введите номер дня недели ');
  readln(day);
  writeln'**************************************');
  case day of
    '1'..'7': writeln('Сегодня - ',week[day]);
    else writeln('Вы ввели неправильный номер дня недели')
  end;
  writeln('**************************************');
end.

 

Добавил блок-схему - только там исправь, пожалуйста, а то я ошибся:

Все блоки вывода должны быть параллелограммами (такие как ввод), а не прямоугольниками. Sorry :)

Ответить

Другие вопросы из категории

Читайте также

Постройте алгоритм и составьте программу, по которой будет реализован следующий сценарий: компьютер запрашивает номер дня недели, после ввода компьютер

сообщает название этого дня. Например, если ввели 1, то выведется фраза "это понедельник" и т.д.

Помогите пожалуйста. Тема циклы. Уменшить данное число на 4, пока оно положительное.

Исполнить x=13.
сделать блок схему и программу на паскале.

составить блок схему по программе на паскалеVar A:array[1..100] of integer;

i,j,imax,n:byte;
Begin
j:=0;
write('Введите размер массива: ');readln(n);
For i:=1 to n do
Begin
readln(A[i]);
if (j=0)and(A[i]<0) then j:=i;
End;
writeln;
if j>0 then
Begin
if j<>n then imax:=j+1
else writeln('Первый отрицательный находится последним');
if imax<>0 then
For i:=imax+1 to n do
if A[i]>A[imax] then imax:=i;
if imax>0 then writeln('Max = ',A[imax]);
End
else writeln('Нету отрицательных');
readln;
End.



Вы находитесь на странице вопроса "составить блок-схемы и программы на Паскале для решении задач: компьютер запрашивает номер дня недели, после ввода компьютер сообщает название", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.