Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Как исправить ошибку?

10-11 класс

Kosmodroma 28 окт. 2014 г., 20:25:48 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Кирри
28 окт. 2014 г., 21:08:29 (9 лет назад)

Двоеточие перед if поменяй ;

Ответить

Другие вопросы из категории

Помогите написать код программы в Pascal для задачи:

дано натуральное число n среди чисел 1,2 ... n найти все те, которые можно представить в виде суммы квадратов двух натуральных чисел.
Заранее огромное спасибо!!

Читайте также

Помогите пожалуйста исправить ошибку "неверная вещественная операция (7.PAS, строка 9)" уже не знаю как исправить задание: для

натурального n и действительного x подсчитать сумму S=-1/2 + 1/2^2 - 1/2^3 +...+(-1)^n / 2^n

program summa;
uses crt;
var n,i:integer; s:real;
begin clrscr;
writeln ('vvedite n');
readln (n);
s:=0;
for i:=1 to n do
s:=s+exp(ln(-1)*i)/exp(ln(2)*i);
writeln ('s=', s);
readln
end.

1. Запишите следующее выражение по правилам программирования:



2. Выпишите недопустимые имена переменных:

a) Nomer;
b) S34;
c) И92;
d) Kol_vo54;
e) 45_A;
i) fg-л23

3. Установите соответствие (с помощью стрелок) между переменной и типом данных:

а) A:=3.234 а) Integer
b) Z:=14 b) Real
c) B:=10351 c) Byte
d) K:=-0.2 d) Word
e) C:= 64000

4. Запишите инструкцию:

а) присваивающую переменной V значение 7;

б) увеличивающую значение переменной Z на 30;

в) вычисляющую значение переменной R по формуле (X2+Y2):2;

5. Опишите переменные, необходимые для вычисления:


при x=-5.3, y=7.42

6. Напишите инструкцию вывода на экран:
а) вашего имени б) числа 400 в) значения выражения 7,3(3,22+8,61)

7. Определите, какое значение примет переменная С в результате выполнения данной последовательности операторов присваивания:

a:=8; b:=a/2; c:=43 mod a; a:=(b+c) div 6; b:=b+1; c:=sqrt(abs(a*b-14));

8. Установите соответствие между служебными словами и названиями разделов программы:

а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

9. Найдите ошибки в записях оператора:

a) Write ©;
b) Writeln;
c) Writeln (Введите любое число);
d) Write X,Y;
e) WRITELN (‘воскресенье, нерабочий день’);

10. Какая структура программы верная:

begin
program MyFirst;
X:=Y+195;
end.


program MyProg;
begin
Writeln (‘Привет’);
end.

11. Расположите в правильном порядке строки программы, вычисляющей периметр и площадь параллелограмма:

1) S:=a*h;

6) var a,b,h,p,s: integer;

2) end.

7) readln;

3) program pr;

8) Writeln(‘p=’,p,’ s=’,s);

4) p:=2*(a+b);

9) a:=6;b:=3;h:=4;

5) Uses crt;

10) clrscr;

11) begin

12. Дан текст программы в таблице с ошибками:

исправьте ошибки в программе;что выведется на экран в результате выполнения программы?

Программа с ошибками

Программа без ошибок

На экране будет напечатано:

War: a,b,c – integer, x: real;
Bigin
A=7, b=3,2, c:=a+b;
Writln (summa=, c);
C:=c/2; x:=a-c;
Writeln(‘x=’ , x, ‘kvadrat=’, x*x);
and

13. Перевести блок-схему на язык Паскаль.

Вычисление расстояния между точками А и B.



Какая тут ошибка, посмотрите, пожалуйста program znacheniya uglov; uses crt; var x: integer; begin writeln('wedite znachenie gradusnoi mery ugla');

read(x); if a=180 then writeln('razvernutyi') else writeln ('ne razvernutyi'); end.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

модуль srt не найден в паскале как исправить вот код

program prim_3;
uses srt;
Label 1;
const
Sob='Вам доступны базы';
var
p:integer;
otv:0..1;
begin
1:clrscr;
Writeln ('Введите ваш пароль');
Readln (p);
clrscr;
gotoxy (10,8);
case p of
1747: Writeln (sob,' A,B,C');
3331,7922: Writeln (sob,' B,C');
8927..9455: Writeln (sob,' C');
else
Writeln ('У вас нет права доступа к базам данных');
end;
gotoxy(15,10);
Writeln ('Будете продолжать работу ''Да-1,Нет-0' );
Readln (otv);
if otv=1 then goto 1;
end.



Вы находитесь на странице вопроса "Как исправить ошибку?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.