Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

сформировать массив из 10 случайных чисел от 2 до 8.

5-9 класс

1)все четные числа разделить на 2,все нечетные увеличить в 3 раза.
2)вывести на экран все числа,которые больше своего соседа слева
ребята,помогите пожалуйста,нужно очень срочно.хотя бы 1 часть)

27102004 14 марта 2017 г., 9:13:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Egoryurin87
14 марта 2017 г., 11:05:42 (7 лет назад)

Program z10;
var a,b: Array [1..10] of integer;
i:integer;
Begin
Randomize;
For i:=1 to 10 do
begin
a[i]:=random(999);
end;
for i:=1 to 10 do
begin
if(a[i] mod 2=0)then [i]:=a[i] div 2 else a[i]:=a[i]*3;
write(a[i],' ');
end;
2)
Program z10;
var a,b: Array [1..10] of integer;
i,r:integer;
Begin
Randomize;
For i:=1 to 10 do
begin
a[i]:=random(999);
end;
r:=a[1];
for i:=2 to 10 do
begin
if(a[i]>r)then write(a[i],' ');
r:=a[i];
end;
end.

Ответить

Другие вопросы из категории

Автоматического устройство имеет два входа, можно подавать на них натуральный числа и наблюдать результат на выходе. По таблице наблюдений

определить правило, по которому автоматического устройство осуществляет преобразования информации.

составить программу нахождения S=1+2+3..+N

уровень 9 класса

что обозначает клавиша Page Up и Page Down????

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!

Читайте также

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.

Дан массив из 10 целых чисел от -20 до 20 и целое число (вводится с клавиатуры).

Напишите программу,определяющую,сколько в массиве чисел.

Задача:

Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!



Вы находитесь на странице вопроса "сформировать массив из 10 случайных чисел от 2 до 8.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.