Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями, кроме умножения, получить:

5-9 класс

 a^{8} за 3 операции.

Kit4nata 03 апр. 2017 г., 2:19:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ZerAlaska
03 апр. 2017 г., 2:58:33 (7 лет назад)

\displaystyle x=a^8={((a^2)^2})^2={((a\times a)^2)}^2 \\ a_1:=(a\times a); \ a_2:=(a_1\times a_1); \ a_3:=(a_2\times a_2)


var
  x,a,b:longint;
 
begin
  a:=3;
  a:=a*a;
  a:=a*a;
  x:=a*a;
  Writeln('3 в степени 8 равно ',x)
end.

Тестовое решение:
3 в степени 8 равно 6561


Ответить

Другие вопросы из категории

Решите задачу:Даша хотела играть на пианино и на флейте.Саша - на трубе или на гитаре.Маша - на гитаре или на барабане.Миша - на флейте или на

трубе.Маленький Яша только на барабане.Может ли их мама так разделить имеющийся в семье музыкальные инструменты
(пианино,флейту,трубу,гитару и барабан),чтобы довольны были все дети?

сформировать массив из 10 случайных чисел от 2 до 8.

1)все четные числа разделить на 2,все нечетные увеличить в 3 раза.
2)вывести на экран все числа,которые больше своего соседа слева
ребята,помогите пожалуйста,нужно очень срочно.хотя бы 1 часть)

Автоматического устройство имеет два входа, можно подавать на них натуральный числа и наблюдать результат на выходе. По таблице наблюдений

определить правило, по которому автоматического устройство осуществляет преобразования информации.

Читайте также

Срочно, решите в паскале!!! ИСПОЛЬЗУЮ ПРОЦЕДУРУ!!!

Дано вещественное а. Не пользуясь никакими арифметическими операциями, кроме умножения , получить:
 а4 за две операции
 а6 за три операции
 а7 за четыре операции
 а8 за три операции
 а9 за четыре операции
 а10 за четыре операции
 а13 за пять операций
 а15 за пять операций
 а21 за шесть операций
 а28 за шесть операций
 а64 за шесть операций



Помогите пожалуйста!!!! Срочно надо!!!!!!

Дано вещественное а. Не пользуясь никакими арифметическими операциями, кроме умножения , получить:
 а8 за три операции
 а9 за четыре операции
 а10 за четыре операции
 а13 за пять операций
 а15 за пять операций
 а21 за шесть операций
 а28 за шесть операций
 а64 за шесть операций

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!



Вы находитесь на странице вопроса "Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями, кроме умножения, получить:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.