Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

строковый тип паскаль: Дана строка. Определить сколько в ней слов оканчиваются на букву «н»

10-11 класс

Ludmilakochukowa 16 апр. 2014 г., 13:11:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kohechka1999
16 апр. 2014 г., 15:50:34 (10 лет назад)

var i,count:integer;
var stroka:string;
begin
  writeln('Vvedite stroku');
  readln(stroka);
  for i:=1 to length(stroka) do begin
    if(stroka[i] = '­н') and (stroka[i+1]= ' ') then inc(count);
    if(i=length(stroka)) and (stroka[i] = '­н') then inc(count);
    end;
  writeln(count);
  readln;

end.

Ответить

Читайте также

Дана строка.Определить сколько раз входит в нее группа букв a b c.

Пожалуйста,не надо писать решай сама!

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

Задание: составить программу решения задачи.

Указания к выполнению: самостоятельно выполнить все этапы решения
задачи. Ввод и вывод матрицы оформить в виде процедур. При
необходимости выделить в задаче вспомогательные алгоритмы и оформить
их в виде подпрограмм.паскаль

Дана матрица, определить количество «особых» элементов. Элемент
считается «особым», если он больше суммы остальных элементов строки.
.

РЕШИТЕ В ПАСКАЛЕ: "Циклический алгоритм "

В данной строке определить количество цифр.

1. Определить, сколько байт содержится в 0.125 Гбайтах. Результат представить как возведенное в степень число 2.

2. Определить, сколько Гбайт содержится в 512 байтах. Результат представить как возведенное в степень число 2.



Вы находитесь на странице вопроса "строковый тип паскаль: Дана строка. Определить сколько в ней слов оканчиваются на букву «н»", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.