Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Шифр Цезаря працює так: кожна буква у вихідному тексті замінюється третьою після нею буквою в алфавіті, літери якого вважаються записаними по колу.

5-9 класс

Розшифруйте слово ТСДКЖСПОЗРРВ, зашифроване цим шифром:

Валерия12121313 24 дек. 2013 г., 17:10:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
202000261073
24 дек. 2013 г., 19:10:53 (10 лет назад)

Алфавiт: Аа Бб Вв Гг Ґґ Дд Ее Єє Жж Зз Ии Iі Її Йй Кк Лл Мм Нн Оо Пп Рр Сс Тт Уу Фф Хх Цц Чч Шш Щщ Ьь Юю Яя

Слово: повiдомлення

Ответить

Другие вопросы из категории

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

ПОЖАЛУЙСТА!!! В классе 1010 мальчиков, что составляет 101000% от численности всего класса. Сколько в классе девочек и какова общая численность

класса? Ответы получите в двоичной системе, в которой записаны все приведенные значения.

Читайте также

Паскаль шифр цезаря

почему при дешифровке в слове с буквой "в" в результате выдаёт восклицательный знак то есть не может его дешифровать?




program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
If k>33 then k:=k-33;
if k<0 then k:=k+33;
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.

Шифр цезаря на паскале , почему не выдает при дешифрации букву В с ключом 3 и 5 и дальше!что исправить?

program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
if a[i]=b[j] then c:=c+b[k];
If k>33 then k:=k-33 else k:=k+33;
end;
writeln(c);
readkey;
end.



Вы находитесь на странице вопроса "Шифр Цезаря працює так: кожна буква у вихідному тексті замінюється третьою після нею буквою в алфавіті, літери якого вважаються записаними по колу.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.