Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ИНФОРМАТИКА, ПОМОГИТЕ. ПАСКАЛЬ, МАССИВЫ.

5-9 класс

Задать случайным образом 10 элементов массива: целые числа из интервала от -5 до 50. Найти:
2) произведение элементов, стоящих на чётных местах;
3) количество отрицательных элементов.
4) Ввести с клавиатуры 12 элементов числового массива. Все положительные увеличить на 100, все отрицательные обнулить.

M1985 10 июня 2013 г., 5:21:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вкусняшечка
10 июня 2013 г., 7:14:18 (10 лет назад)

вот держи,будут вопросы-пиши в лс

+ 0 -
Imanovrasim
10 июня 2013 г., 8:57:40 (10 лет назад)

a: array [1..50] of integer;
i, pr, otr: integer;
begin
randomize;
for i := 1 to 10 do
   a[i] := random(50) - 5;
otr := 0;
pr := a[2];
for i := 1 to 10 do
  begin
     if (a[i] < 0) then inc(otr);
     if (i mod 2 = 0) then
       pr := pr * a[i];
  end;
writeln('Отрицательных - ',otr,' Произведение - ',pr);
for i := 1 to 12 do
 begin
read(a[i]);
if(a[i] > 0) then
inc(a[i],100)
else
a[i] := 0;
write(a[i],' ');
end;
end;


+ 0 -
Byfbfhggtfyhg
10 июня 2013 г., 11:13:16 (10 лет назад)

сейчас напишу.подожди 5 мин

Ответить

Другие вопросы из категории

2 задание плиз очень надо
ПОМОГИТЕ ПОЖАЛУЙСТА,ДАЮ 30 БАЛЛОВ!

Составьте программу ,которая формирует массив ,содержащий 8 случайных целых чисел, принадлежащих промежутку [0;5] ,и преобразует элементы массива по следующему правилу: чётное число умножает на 5 ,а от нечётного отнимает 2.

Читайте также

Помогите решить задачу по информатике в паскале!

Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны!

Нароооооод!Кто смыслит в информатике,помогите пожалуйста решить номер один.Воть:сформируйте массив, содержащий 15 элементов ,с помощью датчику

случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты

Программа по информатике,Программа по информатике, помогите!Программа по информатике, помогите! Имеется n банок с целочисленными объемами

v1, v2, v3..., vn литров, пустой сосуд и кран с водой. Можно ли с помощью этих банок налить в сосуд ровно v литров воды.(Ответ должен выдаваться да или нет) Решение: обозначим s:=nod(v1, v2, v3..., vn) Если v делится нацело на s, то в сосуд с помощью банок можно налить v литров воды, иначе нет.Напишите программу пожалуйста,срочно и полностью, я вообще её не могу понять,помогите!!! :)



Вы находитесь на странице вопроса "ИНФОРМАТИКА, ПОМОГИТЕ. ПАСКАЛЬ, МАССИВЫ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.