Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

две задачи в паскале

10-11 класс

Anzhels 21 июля 2013 г., 12:12:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89022105024
21 июля 2013 г., 15:03:55 (10 лет назад)

1)
const line = 3;
const column = 5;
var a:array [1..line,1..column] of integer;
     i,j,k:integer;
     flag:boolean;
begin
  for i:=1 to line do
     for j:=1 to column do
      begin
        write ('A[',i,'][',j,'] = ');
        readln (a[i][j]);
      end;
  k:=0;
  flag:=false;
  for j:=1 to column do
   begin
     k:=0;
     for i:=1 to line do
      if (a[i][j]<0) then inc(k);
     if (k=2) then
      begin
       flag:=true;
       break;
      end;  
   end;
   if (flag) then writeln ('YES') else writeln ('NO');
end.

2)

+ 0 -
ElenаCru
21 июля 2013 г., 15:40:10 (10 лет назад)

Комментарий удален

+ 0 -
040102
21 июля 2013 г., 18:11:16 (10 лет назад)

да

Ответить

Другие вопросы из категории

Срочно! Составить программу!!!


Количество чисел задается пользователем:
чтобы найти среднее арифметическое надо:

1. запросить у пользователя сколько вводится чисел(N)
2. сравнить количество чисел с нулем
2.1 если количество чисел >0 (т. к. количество чисел должно быть натуральным), то:
2.1.1 т. к. мы будем находить сумму чисел, значит начальное значение следует приравнять 0
2.1.2 выполнять цикл мы будем N раз. В цикле мы должны:
2.1.2.1 запросить число(А)
2.1.2.2 к полученной сумме прибавить введенное число
2.1.3 найти среднее арифметическое введенных чисел
2.1.4 вывести полученное значение
2.2 если количество чисел <=0 то:
2.2.1 вывести сообщение об ошибке.

Упростить формулу (X<=>Y)*(x+y)
Написать программу на Pascale

Даны первые элементы и разности двух арифметических
прогрессий. Определить, в какой из них m-й
элемент больше (m - заданное целое
число).

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Нужно решить задачу в Паскале, условие таково:

Пользователь вводит число заранее неизвестное.
Выяснить есть ли в этом числе хотя бы две одинаковые цифры.

Пожалуйста, помогите с задачей в паскале! Написать решение задачи для программы Паскаль. Спасибо)

Имеется
массив А из N произвольных чисел (А(N)), среди которых есть положительные, отрицательные и
равные нулю. Используя оператор цикла, составить программу, выполняющую задачу:

Решить задачу в Паскале:

Задать случайным образом 8
элементов числового массива – числа от 100 до 200. Вставить в него:

а) число «-20» перед 5-ым
элементом.

б) число «0» перед максимальным элементом. В одной задаче должно быть и а и б (но можно и по отдельности, главное, чтобы было верно)))

Нужно решить задачу в Паскале, условие таково:

"Найти наименьшее кратное двух чисел a и b"

Насколько я помню в этой задаче можно использовать команду Break.




Вы находитесь на странице вопроса "две задачи в паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.