Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

составить программу в которой записать в массив N номера положительных элементов массива (x1,x2...x15)

10-11 класс

Eyey 24 дек. 2013 г., 3:33:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leonid14
24 дек. 2013 г., 6:26:07 (10 лет назад)

var

  N: array [1..15] of 1..15; {Массив, в который записываются номера положительных элементов массива х}

  x: array [1..15] of real; //Массив х

  i: integer; //Переменная для цикла

  Number: integer; //Сколько номеров было записано

begin

  Number:= 0; //Обнуляем счетчик номеров

  for i:= 1 to 15 do   //Вводим с клавиатуры массив х

  begin

    writeln('Введите ', i, ' элемент массива х');

    readln(x[i]);

    if x[i] > 0 then  {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}

    begin

      Number:= Number + 1;

      N[Number]:= i;

    end;

  end;

  write('Номера положительных элементов массива х:  ');

  for i:= 1 to Number do write(n[i], '  '); //Выводим записанные номера элементов

  writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

end.

 

Ответить

Другие вопросы из категории

В какой системе счисления равенство верно?

22+55=110 (желательно с более подробным решением)

Здавствуйте ребята!Помогите пожалуйста решить,перевесети из двочного кода в десятичный код.Числа записаны в парах : 1)101 101 2)1000

1000

3)1001 1000

4)1011 110

5)1100 110

6)1100 111

7)1011 111

8)1011 10

9)1001 10

10)1001 11

11)1010 11

12)1010 100

13)111 100

14)111 10

15)101 10

16)101 11

17)110 11

18)110 1001

19)111 1001

20)111 1000

21)10 1000

22)10 1001

23)11 1001

24)11 110

25)100 101

Или подскажите как решать хотя бы:))Заранее спасибо.

Читайте также

дан массив из 30-ти элементов. Каждый элемент может принимать целочисл

енные значения от -100 до 100. Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. Первый элемент не равен 0. (Паскаль)

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Cтроки. Паскаль. 1.Задано слово - последовательность произвольных символов. Сделать программу, в которой составляется слово перевертыш к данному

( символы записываются в обратной последовательности.)

2.Дана символьная строка. Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "составить программу в которой записать в массив N номера положительных элементов массива (x1,x2...x15)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.