Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана непустая последовательность целых чисел, оканчивающаяся нулем

5-9 класс

(0 является признаком окончания последовательности и в последовательность не входит).
Найти и напечатать:
1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Если таких чисел нет, то напечатать «Таких чисел нет»
2. Количество четных чисел

Его223 16 авг. 2014 г., 2:54:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anitysik
16 авг. 2014 г., 4:29:21 (9 лет назад)

var
a:array[1..1000] of longint;
i,j,k,b,h,v:longint;
begin
i:=2;
readln(a[1]);
while (a[i-1]<>0) do begin readln(a[i]); inc(i); end;
readln(j);
for k:=1 to i-1 do
if a[k]>j then h:=h+a[k] else inc(b);
if b=i-1 then writeln('Takix 4isel netu');
for k:=1 to i-1 do
if a[k] mod 2=0 then inc(v);
writeln(h, ' ,v);
end.
ну при компиляции могут быть ошибки, т.к. писал сразу здесь.. но суть задачи и её решение я вижу именно так

Ответить

Другие вопросы из категории

1. У Саши есть друг в Германии, с которым он общался с помощью электронной почты. Саша решил послать другу свою фотографию (фотография отпечатана на

бумаге). Какое устройство необходимо Саше, чтобы он мог послать свое фото в виде файла?

2. Какие устройства имеют доступ к видеопамяти?

3. Из каких основных цветов формируется вся палитра?

4. Что хранится в видеопамяти?

Результат сложения чисел, записанных в восьмеричной системе счисления:368+36008+3600008+360000008,перевели в шестнадцатеричную систему

счисления. Напишите в ответе через пробел, в порядке возрастания, какие цифры встретились в получившейся записи.

Читайте также

Дана непустая последовательность целых чисел, оканчивающаяся нулем

(0 является признаком окончания последовательности и в последовательность не входит).
Найти и напечатать:
1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Если таких чисел нет, то напечатать «Таких чисел нет»
2. Количество четных чисел

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77. Если такое число
есть, то вывести «Yes». В противном случае вывести «No». Решить данную
задачу двумя способами, используя циклы с пред и пост условиями.( в ПАСКАЛЕ)

Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести

«Yes». В противном случае вывести «No». Решить данную задачу двумя способами, используя циклы с пред и пост условиями.



Вы находитесь на странице вопроса "Дана непустая последовательность целых чисел, оканчивающаяся нулем", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.