Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить комбинированный тип для представления анкеты ребенка, состоящей из его имени, пола и роста. Ввести информацию по 20 детям. Вывести имя самого

10-11 класс

высокого мальчика. Вывести средний рост мальчиков. Далее вывести имена всех мальчиков ниже среднего.

Anna678 17 янв. 2015 г., 6:35:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SonechkoSelyaninova
17 янв. 2015 г., 9:26:41 (9 лет назад)

uses crt;
type zapis=record
im:string;
pol:char;
rost:real;
end;
var
a:array [1..20] of zapis;
n,i:integer;
max,sr:real;
t:string;
w:char;
begin
clrscr;
writeln('kolichestvo detei:');
readln(n);
for i:=1 to n do
begin
writeln('rebenok ',i);
write(' - imya: ');readln(a[i].im);
write(' - pol (m/g): ');readln(a[i].pol);
write(' - rost: ');readln(a[i].rost);
end;
clrscr;
writeln('spisok detei:');
writeln('--------------------------------------------------------');
writeln('Imya':15, ' | ', 'Pol':15, ' | ', 'Rost':20, ' | ');
writeln('--------------------------------------------------------');
for i:=1 to n do
writeln(a[i].im:15, ' | ', a[i].pol:15, ' | ', a[i].rost:20:2,' | ');
writeln('--------------------------------------------------------');
writeln;
max:=a[1].rost;
sr:=0;
for i:=1 to n do
begin
if a[i].rost>max then max:=a[i].rost;
if a[i].pol='m' then sr:=sr+a[i].rost;
end;
sr:=sr/n;
writeln('Samii visokii:');
for i:=1 to n do
if a[i].rost=max then writeln(' - ',a[i].im);
writeln;
writeln('Srednii rost mailchikov: ',sr:5:2);
writeln;
writeln('Malchiki nige srednego:');
for i:=1 to n do
if (a[i].rost<sr)and( a[i].pol='m') then writeln(' - ',a[i].im);
end.

+ 0 -
Yulagavrish
17 янв. 2015 г., 12:17:59 (9 лет назад)

c:array[1..20] of string;
i,j,rost,summ,n:integer;
begin
n:=20;
writeln('введите имена детей');
for i:=1 to n do
readln(b[i,1]);
writeln('введите рост для каждого ребенка по порядку');
for i:=1 to n do
readln(a[i]);
writeln('введите пол ребенка(м или ж)');
for i:=1 to n do
readln(b[i,2]);
for i:=1 to n do
if  a[i]>rost then rost:=a[i];
for i:=1 to n do
if b[i,2]='м' then
summ:=summ+a[i];
for i:=1 to n do
if a[i]<summ/n then
c[i]:=b[i,1];
writeln('средний рост мальчиков=',summ/n);
write('имена мальчиков с ростом ниже среднего:');
for i:=1 to n do
write(c[i],' ');
end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста. Нужно написать программу паскаль.. 7.62. Даны натуральное число n и целые числа a1, a2, a3, …a9. Найти: а) номер максимального из

чисел ai,. Если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. Если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

При передачи информации В ЭВМ с интерфейсом "Общая шина" ЦП чаще всего выступает в роли.

1) Устройства, передающего информацию

2) Исполнителя

3) Задатчика

4) Устройство, принимающего информацию

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение

среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов. Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.

Читайте также

Определить

комбинированный тип для пред­ставления анкеты ребенка, состоящей из его имени,
пола и роста. Ввести информацию по 20 детям. Вывести имя самого высокого
мальчика. Вывести средний рост мальчиков.
Далее вывести имена всех мальчиков ниже среднего.

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, используется неравномерный двоичный код, позволяющий однозначно

декодировать полученную двоичную последовательность. Вот этот код: А – 011, Б – 000, В – 11, Г – 001, Д – 10. Можно ли сократить для одной из букв длину кодового слова так, чтобы код по-прежнему можно было декодировать однозначно? Коды остальных букв меняться не должны. Выберите правильный вариант ответа.

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, используется неравномерный двоичный код, позволяющий однозначно

декодировать полученную двоичную последовательность. Вот этот код: А-0, Б-100, В-1010, Г-111, Д-110. Требуется сократить для одной из букв длину кодового слова так, чтобы код по-прежнему можно было декодировать однозначно?Коды остальных букв меняться не должны,каким из указаных способов можно это сделать?
1)Для букв В-101
2)В-010
3)неизвестно
4)Б-10

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Для групповых операций с файлами используются маски имен файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов

символов, в которых также могут встречаться следующие символы:
Символ «?» (вопросительный знак) означает ровно один произвольный символ.
Символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность.
Определите, какое из указанных имен файлов удовлетворяет маске: ?hel*lo.c?*.
А). hello.c
Б) hello.cpp
В) hhelolo.cpp
Г) hhelolo.c



Вы находитесь на странице вопроса "Определить комбинированный тип для представления анкеты ребенка, состоящей из его имени, пола и роста. Ввести информацию по 20 детям. Вывести имя самого", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.