Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте! Помоги пожалуйста заменить цикл FOR на цикл REPEAT! ОЧЕНЬ СРОЧНО!

10-11 класс

program PRIMER1;
USES CRT;
CONST
A=PI/4;
B=4/PI;
M=20;
VAR
F,H,X:REAL;
i:INTEGER;
BEGIN
CLRSCR;
H:=(B-A)/M;
FOR I:=0 TO M DO
BEGIN
X:=A+I*H;
F:=COS (1/X);
WRITELN ('X=', X:6:3,',F(X)=',F:6:3);
END;
END.

Maksmosko 29 июля 2015 г., 18:52:02 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Orion27
29 июля 2015 г., 20:39:11 (8 лет назад)

Держи.делайте отступы,с отступами код более понятнее

Ответить

Другие вопросы из категории

помогите написать задачу в паскале АBC в файле 1.txt находятся английские слова (записаны столбиком) а в файле 2.txt находятся их русский перевод

запускаем программу вводим английское слова программа должна выдать на экран русский перевод

Видеоадаптер это:

устройство управляющее работой графического дисплея
программа, распределяющая ресурсы видеопамяти
электронное, энергозависимое устройство для хранения информации о графич. изображений
дисплейный процессор

Читайте также

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "Здравствуйте! Помоги пожалуйста заменить цикл FOR на цикл REPEAT! ОЧЕНЬ СРОЧНО!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.