Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задача на C++:

10-11 класс

В одномерном массиве, состоящем из n вещественных элементов, вычислить:
1) количество элементов массива, больших C
2)произведение элементов массива, расположенных после максимального по модулю элемента.
Преобразовать массив таким образом, чтобы сначала располагались все отрицательные элементы, а потом - все положительные
(элементы, равные 0, считать положительными)

Berdnikovanat 02 февр. 2016 г., 16:54:12 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Darёнка
02 февр. 2016 г., 17:27:30 (8 лет назад)

#include <iostream>
#include <cstdio>
#include <cmath>

int main()
{
//Объявление переменных, освобождение памяти под динам.массив
int i=0,n=0,c=0,max=0,k=0;
double p=1.0;
cin>>n,c;
double *massop = new double[n];
double *mass = new double[n];

//узнаём числа>c, а заодно и значение максимума по модулю

+ 0 -
Sofi26012006
02 февр. 2016 г., 18:17:23 (8 лет назад)

сейчас напишу, никуда не девайся ;)

Ответить

Другие вопросы из категории

1. Найти

количество отрицательных чисел во вводимой с клавиатуры последовательности.
Условие окончания ввода – ввод числа 0.
2.

Прошу объяснить решения задач такого типа:

1)Напечатать числа в виде следующей таблицы:
1) 5 5 5 5 5 2) 1 1 1 1 1
5 5 5 5 5 1 1 1 1
5 5 5 5 5 1 1 1
5 5 5 5 5 1 1
1

Язык программирования Си(С).
Меня интересует решение с пояснением такого типа:
"В данной строке задаем сколько элементов будет в строках..." и т.д.

Помогите найти ошибку в программе,

Program nastya;
var n: integer;
Procedure Perewod8(n:integer);
begin
If n>1 then perewod8(n div 8);
write (n mod 8);
end;
begin
write ('введите натуральное число N=');
read(N);
Perewod8(n);
end.

Читайте также

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Решить любую из двух задач. Если две - то спасибо :)

1) В одномерном массиве встречаются нули. Согнать их всех в одну сторону.(задача на пузырьковый метод)
2) После ввода одномерного массива:
-сначало идут положительные по возрастанию

-потом все нули

-потом все отрицательные чила по возрастанию

Пример:-1 5 -7 0 3 0 -2 6 8

вывод: 3 5 6 8 0 0 -7 -2 -1

Помогите, очень прошу вас.

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.



Вы находитесь на странице вопроса "Задача на C++:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.