Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ТЕРМІНОВО!!!!

10-11 класс

ДОПОМОЖІТЬ ДУЖЕ ПРОШУ!!!
Скласти підпрограмму упорядкування N - елементів масиву А у порядку спадання.
Писати у Паскалі.

КотВТанке 27 дек. 2014 г., 3:29:58 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nataliapichugh
27 дек. 2014 г., 4:40:51 (9 лет назад)

Отсортировать элементы массива от большего к меньшему?

Ну сортировка пузырьком например:
program test;
var
arr:array[1..10] of integer;
i,j,n,swp:integer;
begin
n:=10;
for i:=1 to n do
 begin
 arr[i]:=random(100);
 write(arr[i],' ');
 end;

for i:=1 to n-1 do
 for j:=1 to n-i do
  if arr[j]<arr[j+1] then
  begin
   swp:=arr[j];
   arr[j]:=arr[j+1];
   arr[j+1]:=swp;
  end;
writeln;
for i:=1 to 10 do
 write(arr[i],' ');
readln;
end.

Ответить

Другие вопросы из категории

TurboPascal

Даны два массива C(6),D(8). Заполнить C(6) по формуле 3i+1, D(8) по формуле 3i+2. Вывести на экран эти массивы. Найти в C(6) сумму элементов кратных 4, в D(8) - сумму элементов кратных 3, найти их разность. Составить программу, используя процедуры и функцию...ПОМОГИТЕ ПОЖАЛУЙСТА. эта задача будет у меня на экзамене через 2 дня.. Очень нуждаюсь в помощи.

слово презентация с латинского

Читайте также

ТЕРМІНОВО!!! ДО ЗАВТРА!!!

1. Тема: Обробка символьних рядків (даних типу String)
Завдання: Дано рядок символів, який складається з окремих слів, відокремлених інтервалом. Порахувати:
- кількість слів у рядку;
- кількість голосних букв у слові.

2. Тема: Обробка даних типу запис.
Завдання: скласти програму утворення даних типу запис у вигляді таблиці, з подальшим записом її в текстовий файл для створення довідкової інформації. У програмі передбачити створення слідуючих підпрограм-процедур:
2.1. формування 5-7 елементів масиву типу запис з полями, вказаними у індивідуальному завданні, з послідуючим їх записом у текстовий файл.
2.2. виведення на екран елементів масиву записів у відповідності з індивідуальним завданням.
Індивідуальне завдання: Список робітників підприємства: табельний номер, ПІБ, посада, дата прийняття на роботу, оклад. Роздрукувати дані про техніка, отримавшого найбільшу зарплатню.

Писати на Паскалі.
Тому, хто відповість правильно натисну "Краща відповідь і подякую на сторінці". Спам не писати заради балів.

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату

соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Что из перечисленного не является свойством информации?

1.знаки и сигналы могут предоставить информацию только для получателя который способен их воспринять и распознать
2.информация не материальна
3.информация предоставляет новые сведения об окружающим мире, отсутствовавшие до её получения
4.удобство формы представление информации для восприятия потребителем



Вы находитесь на странице вопроса "ТЕРМІНОВО!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.