Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

TurboPascal

10-11 класс

Даны два массива C(6),D(8). Заполнить C(6) по формуле 3i+1, D(8) по формуле 3i+2. Вывести на экран эти массивы. Найти в C(6) сумму элементов кратных 4, в D(8) - сумму элементов кратных 3, найти их разность. Составить программу, используя процедуры и функцию...ПОМОГИТЕ ПОЖАЛУЙСТА. эта задача будет у меня на экзамене через 2 дня.. Очень нуждаюсь в помощи.

Duratupayaa 16 дек. 2014 г., 8:32:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shopogolik
16 дек. 2014 г., 9:46:35 (9 лет назад)

program main;
var i,r,sum1,sum2:integer;
c:array[1..6] of integer;
d:array[1..8] of integer;
type mass=array[1..8] of integer;
type ms=array[1..6] of integer;
procedure sum4(b:ms;var s4:integer);
var j:integer;
begin
s4:=0;for j:=1 to 6 do if ms(b)[j] mod 4=0 then s4:=s4+ms(b)[j];
end;
procedure sum3(a:mass;var s3:integer);var j:integer;
begin
s3:=0;
for j:=1 to 8 do if mass(a)[j] mod 3=0 then s3:=s3+mass(a)[j];
end;
function dif(x,y:integer):integer;
begin
dif:=x-y;
end;
begin
for i:=1 to 8 do d[i]:=3*i+2;
for i:=1 to 6 do c[i]:=3*i+1;
r:=dif(sum4(c,sum1),sum3(d,sum2));
writeln(r);
end.

+ 0 -
DrPepsi
16 дек. 2014 г., 11:28:07 (9 лет назад)

что интересно, изменение s не даёт изменений в результате оО

+ 0 -
Yzhosan
16 дек. 2014 г., 12:24:35 (9 лет назад)

нашла ошибку, сейчас кину

+ 0 -
Аssassin
16 дек. 2014 г., 14:58:46 (9 лет назад)

Program a1;
Type mas=array[1..8] of byte;
Var c,d:mas;
Procedure vvod (var x:mas; n,t:byte);
var i:integer;
begin
For i:=1 to n do
x[i]:=3*i+t;
end;
Procedure pech (var x:mas; n:byte);
var i:integer;
Begin
For i:=1 to n do
write (x[i],' ');
writeln;
end;

+ 0 -
чижиха
16 дек. 2014 г., 17:20:10 (9 лет назад)

Function sum (x:mas; n,t:byte):byte;
var i,s:byte;
Begin
s:=0;
For i:=1 to n do
If x[i] mod t=0 then s:=s+x[i];
sum:=s;
end;
Begin
Vvod (C,6,1); pech (C,6);
Writeln;
Vvod (D,8,2); pech (D,8);
Writeln;
Write (sum(C,6,4)-sum(D,8,3));
end.

+ 0 -
Kellylove
16 дек. 2014 г., 18:45:37 (9 лет назад)

удали моё решение

Ответить

Другие вопросы из категории

слово презентация с латинского
1. Проводится 2 лотереи 4 из 32 и 5 из 64. В какой лотерее выгодней участвовать? 2.Сколько бит информации несет сообщение о том, что из колоды в

32 карты достали даму пик?

3.Придумать пример системы выделить составные части, структуру и системный эффект.

Пожалуйста помогите, Оочень надо. Заранее спасибо :)

Читайте также

1) Проводя эксперимент, профессор Петров все измерения производил с помощью исправных датчиков и измерительных приборов. Какое свойство информации при

получении информации опытным путем сохраняется?
Достоверность; Объективность; Полнота; Актуальность.

2) Какой язык НЕ относится к формальным языкам:

A) Нотная грамота;

B) Азбука Морзе;

C) Язык программирования TurboPascal;

D) Хинди.

при поступлении в вуз абитуриенты получившие двойку на первом экзамене ко второму не допускаются. в массиве A[n] записаны оценки экзаменующихся,полученные

на первом экзамене. подсчитать, сколько человек не допущено ко второму экзамену .В Turbopascal

ребята нужна помощь,очень важно в turbopascal решить занести в файл 3 записи,каждая из которых представляет

собой совокупность трех полей:фамилия ,год рождения,женат или нет

Иванов 1970 да

Петров 1972 нет

Сидоров 1969 да.

распечатать содержимое полученного файла

Затем считать из файла эту информацию и напечатать:

1-я запись-Иванов 1970 да

2-я запись-Петров 1972 нет

3-я запись-Сидоров 1969 да



Вы находитесь на странице вопроса "TurboPascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.