Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан

10-11 класс

двумерный массив a,
размером (nm).
Переставить каждый элемент побочной
диагонали с элементом первого столбца. код паскаль....

Zhelonkinaa 22 дек. 2013 г., 20:07:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastenakhegay
22 дек. 2013 г., 21:01:57 (10 лет назад)

Var a:array [1..50,1..50] of integer;
m,n,i,j,k,b:integer;
begin
writeln ('Введи количество столбцов и строк');
readln (n,m);
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write (a[i,j]:4);
end;
writeln;
end;
for i:=1 to n do
for j:=1 to m do
if n=i+j-1 then begin
k:=a[i,j];
b:=b+1;
a[i,j]:=a[b,1
];
a[b,1]:=k;
end;

writeln;
for i:=1 to n do begin
for j:=1 to m do
write (a[i,j]:4);
writeln;
end;
readln;
end.

Ответить

Другие вопросы из категории

можно ли записать данную программу используя циклы While и Repeat?Если да то предложите свой вариант.

program 5;
uses crt;
var i,n:integer ; x,y,s,p: real;
begin
x:=4.1; S:=0; P:=1;n:=10;
for i:=1 to n do
begin
s:= s+ ln(sqr(x)+I);
P:= p*(i+4*cos(x+I));
end;
Y:= s+p;
writeln('___x=',x:5:1,'___Y=',y:10:2);
writeln('___s=',s:5:3,'___P=',p:10:2);
end.

Товар стоит a руб. b коп. За него заплатили c руб. d коп. Сколько сдачи требуется получить? Вводятся 4 числа: a, b, c и d. Необходимо вывести 2 числа: e и

f, число рублей и копеек, соответственно. паскаль! помогите пожалуйста, дуб дубом в программировании((((

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Дан", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.