Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Линейный алгоритм.

5-9 класс

Найдите среднее арифметическое d=a+b+c/3
a b c -целые числа, заданны с клавиатуры

ParamoreZz 12 янв. 2014 г., 19:09:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maria1511
12 янв. 2014 г., 21:23:42 (10 лет назад)

var a,b,c,s:real;
begin
writeln ('Введите a, b, c: ');
readln (a,b,c);
s:=(a+b+c)/3;
writeln ('Их среднее: ',s);
end.

Ответить

Другие вопросы из категории

Помогите!!! По информатике.
Дайте несколько возможных общих имен каждой группе объектов. Выберите из них самое подходящее. Ответ обоснуйте:а) Перу, Чили, Эквадор;

б) Эркюль Пуаро, Шерлок Холмс, комиссар Мегрэ;
в) Москва, Санкт-Петербург, Новосибирск;
г) Конго, Нил, Замбези;
д) повесть «Капитанская дочка», роман «Евгений Онегин», стихотворение «Туча»;
е) Москва, Санкт-Петербург, Тула.

Двум англичанам (АА) и двум их проводникам (ПП) из местного племени требуется перебраться на противоположный берег реки.В наличии имеется лодка вмещающая

2-ух человек. Англичане подозревают, что проводники -из племени людоедов, чувствуют себя в безопасности только тогда, когда находятся рядом друг с другом. Как устроить безопасную переправу?

Читайте также

1)Дан фрагмент линейного алгоритма.

а:=8

b:=6+3*а

а:=b/3*а

Чему равно значение переменной а после его исполнения?


Ваш ответ:

2)Исполните следующий фрагмент линейного алгоритм для а = х и b = y.

а:=а+b

b:=b-a

а:=а+b

b:=-b

Какие значения присвоены переменным a и b?

а)-у, х
б)y, х
в)х, у
г)х+у, х-у

3)Определите значение целочисленных переменных х и у после выполнения фрагмента программы.

х:=11

у:=5

t:=y

у:=х mod у

x:=t

y:=y+2*t

а)х = 10, у = 5
б)х = 5, у = 11
в)x = 11, y = 5
г)х = 5, у = 10

4)Среди четырёх монет есть одна фальшивая. Неизвестно, легче она или тяжелее настоящей. Какое минимальное количество взвешиваний необходимо сделать на весах с двумя чашками без гирь, чтобы определить фальшивую монету?

а)4
б)2
в)5
с)3

Какой из алгоритмов не является линейным?

А) мытье посуды
Б) расчет стоимости 2 апельсинов
В) включение компьютера
Г) кипячение чайника

Выберите пример линейного алгоритма.
А) измерение расстояние до предмета
Б) Царевич у камня с надписью о разных путях
В) действие кота ученого из Лукоморья
Г) наполнение бочки с водой при помощи ведра

№1)Составьте алгоритм возведения четного числа в квадрат ,а нечетного к куб. №2)Известно,что 1 миля=7 верст,1 верста=500 сажений,1 сажен

ь=3 аршина,1 аршина=28 дюймов,1 дюйм=25,4мм.Пользуясь этой информацией,состаьте линейный алгоритм перевода растояния х миль в километры.



Вы находитесь на странице вопроса "Линейный алгоритм.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.