Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Тема<Одномерные массивы> Дано N чисел. Найдите сумму чисел,больших заданного числа А

10-11 класс

Demina578 18 дек. 2014 г., 4:19:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Алeкс
18 дек. 2014 г., 5:15:32 (9 лет назад)

Program n1;
Uses CRT;
Const n=10;
Var x:array[1..n] of integer;
i,s,a: integer;
begin
Writeln('Vvedite chisla');
For i:=1 to n do
readln(x[i]);
Writeln('Vvedite A');
Readln(a);
For i:=1 to n do
if x[i]>a then s:=s+x[i];
Writeln('Summa elementov, bolshih a =',s);
readln
end.

Ответить

Другие вопросы из категории

Microsoft Office 365 — это облачное проприетарное программное обеспечение компании Microsoft. Особая версия офисного пакета Office365 предназначена для

использования в образовательных учреждениях.Облачные программные продукты используются в школах для:
1) больших и сложных вычислений;
2) повышения имиджа школы;
3) работы с документами, электронной почтой и системами совместной работы над проектами;
4) для коррекционной работы со школьниками с девиантным поведением.

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

Читайте также

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Тема<Одномерные массивы> Дано N чисел. Найдите сумму чисел,больших заданного числа А", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.