Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

с клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти произведение чисел из введенной

10-11 класс

последовательности кратных пяти

TrueProject 09 февр. 2015 г., 4:16:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Reg63
09 февр. 2015 г., 5:47:43 (9 лет назад)

var
  x, s: integer;

begin
  s := 1;
  repeat
    readln(x);
    s *= (x = 0 ? 1 : x);
  until (x = 0);
  writeln(s);
end.

Ответить

Другие вопросы из категории

Помогите решить пожалуйста!!!

P.S. Не могу получить правильный ответ

составить блок схему по программе на паскалеVar A:array[1..100] of integer;

i,j,imax,n:byte;
Begin
j:=0;
write('Введите размер массива: ');readln(n);
For i:=1 to n do
Begin
readln(A[i]);
if (j=0)and(A[i]<0) then j:=i;
End;
writeln;
if j>0 then
Begin
if j<>n then imax:=j+1
else writeln('Первый отрицательный находится последним');
if imax<>0 then
For i:=imax+1 to n do
if A[i]>A[imax] then imax:=i;
if imax>0 then writeln('Max = ',A[imax]);
End
else writeln('Нету отрицательных');
readln;
End.

По данным x, y составить программу в Паскале для вычисления функции z:

1) z=(min(x, y)+0,5))/(1+max^2(x, y)).

2)z=система max(x, y), x<0
min(x, y), x>=0.

Читайте также

№1.Составьте программу,выбирающую из всех вводимых в ЭВМ чисел только те, которые входят в интервал от 1 до 5.Ввод производится до тех пор пока сумма

всех введенных данных чисел не будет равна 177. №2. Определите диаметр круга, радиус, площадь, если известна длина окружности L. №3.Даны два действительных числа А, В. Найти наибольшее из них и выяснить четное оно или нет.

Дана последовательность чисел a1, a2, …, an. Требуется переставит числа в поряд-ке возрастания. Для этого сравниваются два соседних числа ai и ai+1. Если

ai>ai+1 то делается пере-становка. Так продолжается до тех пор, пока все элементы не станут расположены в порядке воз-растания. Составить алгоритм сортировки, подсчитывая при этом количество перестановок.
ПОМОГИТЕ СДЕЛАТЬ В ПАСКАЛЬ, ПРОШУ =*(



Вы находитесь на странице вопроса "с клавиатуры вводится последовательность чисел до тех пор пока не будет введено число 0. требуется найти произведение чисел из введенной", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.