Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Условные

10-11 класс

операторы

1 Из трех
данных чисел выбрать наименьшее и наибольшее.

Леха135790 08 мая 2014 г., 11:34:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kanz488
08 мая 2014 г., 14:14:07 (10 лет назад)

VAR
   a,b,c,mx,mn: LongInt;
BEGIN
   Read(a,b,c);
   if (a >= b)and(a >= c) then mx := a;
   if (b >= a)and(b >= c) then mx := b; 
   if (c >= a)and(c >= b) then mx := c; 
   
   if (a <= b)and(a <= c) then mn := a;
   if (b <= a)and(b <= c) then mn := b; 
   if (c <= a)and(c <= b) then mn := c;     

   Writeln('Минимальное число  = ', mn);
   Writeln('Максимальное число = ', mx); 
END.
----------------------------------------------------------------------
VAR
   x,y: Real;
BEGIN
   Read(x, y);
   
   if (x <= 0)and(y >= 0) then Write('True')
   else Write('False');
END.
----------------------------------------------------------------------
VAR
   n: LongInt;
BEGIN
   Read(n);
   if (n > 0) then Inc(n);
   Write(n);
END.

Ответить

Читайте также

1. Расширение файла, как правило, характеризует:

тип файла

программное обеспечение

название программы

2. Файл - это:

поименованный объект, расположенный на диске

поименованная совокупность байтов, размещенная на внешнем носителе

совокупность поименованных ячеек памяти

3. Задан полный адрес файла: c:\documets\prikaz.doc. Какое у файла составное имя?

prikaz.doc

documets\prikaz.doc

documets\prikaz

^ 4. К сервисным системам относятся:

интерфейсные системы

инструментальные системы

утилиты

программные системы

оболочки

^ 5. Какое программное обеспечение обеспечивает рабочую среду для других программ:

прикладное

системное

инструментальное

^ 6. Какая версия программного продукта является более новой:

MS DOS 6.0

MS DOS 6.20

MS DOS 6.22

7. Программы, скачанные из Интернета и имеющие определенный срок пользования, являются:

платными

бесплатными

условно-бесплатными

^ 8. Интерфейс, в котором для управления компьютером используются объекты, называется:

объектно-ориентированным

графическим

командным

^ 9. Программы, которые существенно меняют пользовательский интерфейс, не меняя при этом программный, относятся к:

утилитам

интерфейсным системам

оболочкам

^ 10. Какой шаблон позволяет найти файлы, которые начинаются на букву f, заканчиваются на t и имеют любое расширение:

*f????t.*

f*?d.*??

f?*d.*

^ 11. Сколько различных операционных систем можно установить на одном жестком диске:

только одну

только две

только три

12. Какое максимальное число логических дисков можно создать в расширенном разделе:

три

любое

23

13. После форматирования диска его доступный объем может уменьшиться по причине:

наличия на диске логических ошибок

наличия испорченных секторов

наличия фатальных ошибок

1)В каких двух форматах представляются числа? В чём разница между ними? 2)Сформулируйте правила записи формул. Что произойдёт, если при вводе

формулы вы нарушите эти правила?

3)Как можно заранее подготовить таблицу для вычислений?

4)Какие вычисления можно проводить над целыми диапазонами?
5) Что понимается под манипулированием с диапазонами ЭТ?
6)Что такое принцип относительной адресации? В каких ситуациях он проявляется?

7)В ячейке D7 записана формула (C3 + C5)/D6. Как она изменится при переносе этой формулы в ячейку? a) D8; b)E7; c)C6; d)F10?

8)В ячейке Е4 находится формула СУММ(А4:D4). Куда она переместится и как изменится при:
А) удалении строки 2;
В) удалении строки 7;
С) вставке пустой строки перед столбцом 6;
Г) удалении столбца 3;
Д) вставке пустого столбца перед столбцом 6;

1)Как в ЭТ реализуется логическая операция при записи условной функций?

2)Что такое абсолютный адрес?

3)Что такое деловая графика?

4)Какой вид имеет условная функция?

Если емкость одного условного печатного листа равна приблизительно 96 Кбайт, а 1 символ занимает 8 бит, то сколько минут потребуется для распечатки

текста одной газеты (4 усл. п.л.) на лазерном принтере (скорость печати - 512 символов в секунду) без учета смены бумаги.
только максимально подорбно. прошу вас!!



Вы находитесь на странице вопроса "Условные", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.