Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

сколько существует четырехзначных чисел, в записи которых имеются две цифры семь

10-11 класс

Chupriyanov 18 нояб. 2014 г., 11:21:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pawele344
18 нояб. 2014 г., 13:20:32 (9 лет назад)

var k,i,a,b,c,d,m:integer;
begin
for i:=1000 to 9999 do
  begin
  m:=0;
  a:=i div 1000; if a=7 then m:=m+1;
  b:=i div 100 mod 10; if b=7 then m:=m+1;
  c:=i div 10 mod 10; if c=7 then m:=m+1;
  d:=i mod 10;  if d=7 then m:=m+1;
  if m=2  then k:=k+1;
  end;
writeln(k);
end.
---
Это если надо программу написать.
Если просто число нужно, то 459 чисел (по крайней мере так посчитала эта сама программа).

Ответить

Другие вопросы из категории

объясните) плис

Книга состоит из 250 страниц, в каждой странице 32 строки, на каждой строке по 75 символов. Определите объем информации в Кб?

плз решите..... 1, 2
Практичекая по информатики.Помогите пожалуйста

1. Какие значения будет принимать величина- счетчик при выполнении следующего цикла: от f=100 до 1000 шаг a
2. Количество рыбы в реке, в которую сбрасывались загрязнения, ежегодно сокращалось на 20%. Определить, через сколько лет в реке почти не останется (ее количество будет меньше 1) рыбы? Извеcтно, что до начала загрязнения ее было N особей.

Читайте также

Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF



Вы находитесь на странице вопроса "сколько существует четырехзначных чисел, в записи которых имеются две цифры семь", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.