Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

найти среднее арифметическое всех средних чисел от а до в решение в паскале пожалуйста

5-9 класс

1ZoD1 31 авг. 2015 г., 15:21:07 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Igor12345
31 авг. 2015 г., 16:44:09 (8 лет назад)

Var n,s,k,i : integer;
Begin
writeln ('Введите кол-во чисел');
readln (n);
for i:=1 to n do
begin
writeln ('Введите ',i,' число');
readln (k);
s:=s+k;
end;
writeln ('Среднее арифметическое =',s/n:5:2);
End.

Ответить

Другие вопросы из категории

С помощью калькулятора вычислите примеры:

1*11=11
11*11=121
111*111=12321
1111*1111=1234321
11111*11111=123454321
В полученных результатах выявилась следующая закономерность:
(напиши)

Переведите ГБ в мегабайты 0,8 ГБ

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "найти среднее арифметическое всех средних чисел от а до в решение в паскале пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.