Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Решить на языке паскаль!!!!!

5-9 класс

Дано пятизначное число
1)зачеркнуть последнюю цифру
2)зачеркнуть первые 2 цифры
3)зачеркнуть предпоследнюю цифру
4)зачеркнуть три последние цифры
ЧИСЛО 53714
пОМОГИТЕ ПЛИЗЗЗ

Trismigist 02 янв. 2015 г., 0:10:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lollyyyy
02 янв. 2015 г., 2:09:21 (9 лет назад)

1) program z1; uses crt; var a: integer; begin clrscr; repeat write('enter a: '); readln(a) until (a>=10000) and (a<=99999); a:=a div 10; Writeln (a); Readkey; End. 2) program z2; uses crt; var a: integer; begin clrscr; repeat write('enter a: '); readln(a) until (a>=10000) and (a<=99999); a:=a mod 1000; Writeln (a); Readkey; End. 3) program z3; uses crt; var a, b: integer; begin clrscr; repeat write('enter a: '); readln(a) until (a>=10000) and (a<=99999); b:=a mod 10; a:=a div 100; Writeln (a, b); Readkey; End. 4) program z4; uses crt; var a: integer; begin clrscr; repeat write('enter a: '); readln(a) until (a>=10000) and (a<=99999); a:=a div 1000; Writeln (a); Readkey; End.

Ответить

Другие вопросы из категории

Отдаю последние баллы!

Переменные а и b описаны в программе как целочисленные. Определите значение переменной а после выполнения следующего фрагмента программы:
a:=374;
b=div(a,100);
a:=mod(a+b,10);
a:=a*b
где dim и mod функции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно.
В ответе укажите одно число - значение переменной а
Желательно с решением!

сайт хороших сочинений???
Помогите пожалуйста, очень срочно!

Нужно написать программу,где машина должна будет тебе выдать название месяца, сколько дней в этом месяце и какой это день недели.
Решить нужно в Pascal

Помогите пожалуйста срочно на завтра!!!!! В составе каких предметов и существ есть такие части? (Запиши как можно больше названий рядом с каждой

частью.)

Обведи рисунок, на котором есть все перечисленные части.

СЛОВА:

КОЛЕСО----------------------------------

ОКНО--------------------------------------

ХВОСТ------------------------------------

КРЫЛО-----------------------------------

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

помогите, пожалуйста, решить задачу... написать программу на языке Паскаль Продав квартиру, вы получили 22000 долларов и

положили их в банк. Банк начисляет 18% в первый месяц, а каждый следующий - тоже 22%, но уже с общей суммы с учётом начисленных процентов. Сколько денег будет в банке на вашем счету через год? (Нестабильностью нашей экономической системы пренебрегаем)

Паскаль, помогите!!!

Дан фрагмент программы, который решает задачу поиска номера последней минимальной цифры в записи десятичного целого числа (считается, что цифры в числе пронумерованы справа налево) и выводит ее на экран. Определите, какой оператор необходимо вставить вместо троеточия ( . . . ), чтобы правильный результат выдавался для любого целого числа N. Все используемые переменные имеют целый тип данных. Ответ записывайте без пробелов.
на языке Паскаль
readln(N);
MC:=9; I:=0; K:=1; N:=abs(N);
while N< >0 do
begin
С:=N mod 10; N:=N div 10;
I:=I+1;
if ... then
begin
MC:=C; K:=I;
end;
end;
writeln(K); .
10 минут осталось, подалуйста.



Вы находитесь на странице вопроса "Решить на языке паскаль!!!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.