Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

пожалуйста паскаль АВС через цикл FOR.

10-11 класс

Дана строка.Определить сколько букв "к" в последнем слове.

артём3124 16 февр. 2017 г., 0:20:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hatayna
16 февр. 2017 г., 1:53:04 (7 лет назад)

var
  i, n, k: integer;
  s, c: string;

begin
  writeln('Введите текст');
  readln(s);
  n := Length(s);
  k := 0;
  i := n;
  repeat
    c := Copy(s, i, 1);
    if (c = 'к') or (c = 'К') then k := k + 1;
    i := i - 1;
  until c = ' ';
  writeln('В последнем слове буква "k" встречается ', k, ' раз(а)')
end.

Результат прогона тестового примера в PascalABC.NET:

Введите текст
Кукушка кукует, а петух - кукарекает!
В последнем слове буква "k" встречается 3 раз(а)


+ 0 -
Zemenova
16 февр. 2017 г., 3:23:14 (7 лет назад)

Комментарий удален

+ 0 -
Raidan967
16 февр. 2017 г., 6:02:54 (7 лет назад)

через репид?

+ 0 -
Katya2305
16 февр. 2017 г., 6:35:28 (7 лет назад)

Комментарий удален

+ 0 -
Natali5325
16 февр. 2017 г., 7:29:51 (7 лет назад)

s, c: string; здесь" с "-это что?

+ 0 -
Ambaryan1
16 февр. 2017 г., 9:15:26 (7 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не

превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно; или сумме максимального и минимального из них, если минимальное число неотрицательно.

Ничего, кроме указанного числа, программа выводить не должна.

С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.
Каждое число программа должна выводить в отдельной строке; ничего, кроме чисел, программа выводить не должна.

С3. См. фото.



Нужно написать на Паскале=))

Дан набор слов, разделенных точкой с запятой (;), который заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой «а»

Читайте также

ПАСКАЛЬ АВС

ОЧЕНЬ СРОЧНО,ПОЖАЛУЙСТА


При помощи функции trunc() в Паскале можно реализовать операции целочисленного деления и взятия остатка от деления. Например:
целочисленное деление - trunc(491/240) - результатом будет 2;
остаток от деления - 491-240*trunc(491/240) - результатом будет 11.
Используя функцию trunc(), напишите программу, считающую сдачу в английской денежной системе (в этой денежной системе 1 фунт стерлингов равен 20 шиллингам, а 1 шиллинг равен 12 пенсам). Напишите программу, в которой в трёх константах хранится стоимость товара. Одна константа - фунты (целое значение больше нуля), вторая - шиллинги (значение от 0 до 19), третья - пенсы (значение от 0 до 11). Ещё в трёх таких же константах хранится плата покупателя. Используя одну целочисленную переменную, программа должна сосчитать и вывести на экран сдачу в фунтах, шиллингах и пенсах. НЕ ИСПОЛЬЗОВАТЬ УСЛОВНЫЙ ОПЕРАТОР

ПРОГРАММА ДОЛЖНА БЫТЬ НАПИСАНА НА ПАСКАЛЕ АВС

Помогите пожалуйста.паскаль АВС

Треугольник задан координатами своих вершин.Составить программу вычисления площади треугольника.

Найти сумму произведений a и b. a, b вводятся в цикле их 4 пары. Блок-схема.

Объясните пожалуйста еще цикл for to do и счетчик, для чего он служит.



Вы находитесь на странице вопроса "пожалуйста паскаль АВС через цикл FOR.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.