Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано четырёхзначное число, определить:

10-11 класс

1. Входит ли в него цифра 4.

34вася 09 июня 2014 г., 14:16:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлечкка
09 июня 2014 г., 15:50:54 (9 лет назад)

Pascal:
var n:integer;
     f:boolean;
begin
  f:=false;
  repeat
    write ('N = ');
    readln (n);
  until (n>=1000) and (n<=9999);
  while (not f) and (n<>0) do
   begin
    if n mod 10 = 4 then f:=true;
    n:=n div 10;
   end;
  if f then writeln ('YES') else writeln ('NO');
end.

C++:
#include <iostream>
using namespace std;

int main()
{
  int n;
  bool f = false;
  while (n<1000 || n>9999)
  {
    cout <<"N = ";
    cin >>n;
  }
  while (!f && n!=0)
  {
    if (n%10==4)
      f = true;
  }
  if (f)
    cout <<"YES" <<endl;
  else cout <<"NO" <<endl;
  return 0;
}

Ответить

Другие вопросы из категории

я включив комп'ютер та почав грати у свою улюблену гру, швидко рухаючи . Отримавши рекордний результат, я ввів з. своє ім'я та роздрукував на. список

рекордсменів. Потім набрав на. невеличку розповідь про відпочинок влітку, переписав з. фотографіі, додав іх до тексту розповіді та переглянув на.

//---------------------------------------------------------------------------

#include <stdio.h>
#include <conio.h>
#pragma hdrstop
//---------------------------------------------------------------------------
#pragma argsused
int main(int argc, char* argv[])
{ int a[10],m,n,k,i;
m=n=k=0;
for(i=0;i<9;i++)
{scanf("%d",&a[i]);
if(a[i]>0 && a[i+1]<0) k++,m=a[i],n=a[i+1],printf("\n %d %d",m,n);
if(a[i]<0 && a[i+1]>0) k++,m=a[i],n=a[i+1],printf("\n %d %d",m,n);
if(k==4) break;
};
getch();
return 0;
}
//---------------------------------------------------------------------------

Это С++,задача состоит в том чтобы вывести первые 4 пары смежных символов со противоположными знаками (+ - или - +).Только где-то в коде ошибка...Помогите найти ее...

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

QUICKBASIC. Циклы




1. Вычислить и распечатать значения функции Y= A^2 + B^2 при одновременном
(синхронном) изменении величин А и В:

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1. Дано шестнадцатиричное число 12CD. Получить его двоичный аналог.

2. Дано десятичное число X=563. Представить его в ячейке.
3. Дано десятичное число X= -62. Представить его в восьмиразрядной ячейке.
4. Дана шестнадцатеричная запись числа X=FB32 в ячейке. Получить исходное число в десятичной системе.

нужно как из четырёхзначного числа сравнить первую и последнюю цифру и две средних вопрос в том что как их вытащить из этого числа? первую и последнюю я

понял как
Console.WriteLine("Введите четырёхзначное число");
m = int.Parse(Console.ReadLine());
a = m / 1000; //последняя 1 цифра
b = m % 10;
допусти я ввёл число 6432 то прога выводит мне 6 и 2 мне надо ещё как то отдельно вывести цифры 4 и 3 и задать им отдельные переменные что бы сравнить



Вы находитесь на странице вопроса "Дано четырёхзначное число, определить:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.