Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пожалуйста.

10-11 класс

Дан массив {Tij}, состоящий из n строк, l столбцов. Найти сумму положительных элементов, имеющих нечетный номер.

Serg1997serg 30 дек. 2013 г., 18:21:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ainurmuhamatya
30 дек. 2013 г., 20:27:15 (10 лет назад)

программа написана для языка С++
#include <iostream>
#include <stdio.h>
#include <time.h>
int main ()
{ srand(time(0));
int T[i][j];
int s=0,n,l;
cout<<"vvedite kol-vo strok:";
cin>>n;
cout<<"vvedite kol-vo stolbcov:";
cin>>l;
for (int i=0;i<n;i++)
{ for (int j=0; j<l; j++)
T[i][j]=rand()%7+1;
cout<<T[i][j]<<" ";
if (i % 2== 0) && (j%2==0) && (T[i][j]>0)
s=s+T[i][j];}
cout<<endl;}
cout<<"summa elementov ="<<s;
cin.get();
cin.get();
return 0;
}

+ 0 -
Rubanova11
30 дек. 2013 г., 21:25:12 (10 лет назад)

двумерный массив имеет номер строки и номер столбца. а какой именно нечетный номер вам нужно ?

Ответить

Другие вопросы из категории

Какое значение будет выведено в результате исполнения алгоритма ?

Нач
к:=2; к1:=1; с:=59
Нц для I от 50 до 164
С:=с+к*I; k:=k+k1; k1:=-k1
Кц
Выаод с
Кон
Ответы 1) 30762 2) 30764 3) 30766 4) 30768 5) 30770

4^2013+2^2012-15

Сколько единиц в двоичной записи результата

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "помогите пожалуйста.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.