Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решение задач с использованием файлов

10-11 класс

1. Дано число к и файл, содержащий целые числа. Вывести элемент файла с номером к. если такой элемент отсутствует, то вывести 0.

2. Дан файл вещественных чисел. Создать 2 новых файла, в первый из которых содержит строки исходного файла с четными номерами, а второй с нечетными номерами.

Zabavnaya 03 дек. 2013 г., 21:22:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маряно
03 дек. 2013 г., 21:55:57 (10 лет назад)

1)
var   k,a,i,n : integer;
   t : Text;
    begin 
 readln (k);
 n := 0;
  Assign (t,'test.txt');
  Reset(t);
  i := 1;
   while not Eof(t) do
    begin   
 read (t,a);   
   if a = k then 
     n := i;   
   i := i +1;  
   end; 
  Close (t); 
 writeln (n);
 end.

2)


 var 
 t,t1,t2 : Text;
  i : integer;
  a : real;
 begin
  Assign (t,'text.txt'); 
 Reset (t);
  Assign (t1,'r1.txt');
  rewrite (t1); 
 Assign (t2,'r2.txt'); 
 rewrite (t2); 
   i := 1; 
   while not Eof(t)
 do  
 begin 
   read (t,a); 
    if i mod 2 = 1 then
      write (t1,a:3:3,' ') 
      else 
       write (t2,a:3:3,' ');
    i:= i +1;  
    end;  
  Close (t); 
 Close (t1); 
 Close (t2);
 end.

Ответить

Другие вопросы из категории

световое табло состоит из лампочек каждая из которых может находиться в трех состояниях включено выключено мигает какое наименьшее количество лампочек

должно находиться на табло чтобы с его помощью можно было передать 50 различных сигналов

пожааааалуйста, помогите с информатикой )

а то я не умею этот pascal

Читайте также

Задание: составить программу решения задачи.

Указания к выполнению: самостоятельно выполнить все этапы решения
задачи. Ввод и вывод матрицы оформить в виде процедур. При
необходимости выделить в задаче вспомогательные алгоритмы и оформить
их в виде подпрограмм.паскаль

Дана матрица, определить количество «особых» элементов. Элемент
считается «особым», если он больше суммы остальных элементов строки.
.

Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:


Вычислить
сумму положительных элементов матрицы А (10х10), расположенных над главной
диагональю. Индекс номера строки i изменяется
от 1 до 9, а индекс номера столбца j изменяется от –i+1
до 10.

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.

Задача.

Производиться одноканальная (моно) звукозапись с частотой дискретизации 16 килогерц.
и 24 битным разрешением. Запись длится 1 минуту. Сжатие данных не производится. Какой размер файла полученого в мегабайтах, вы найдете?

Пожалуйста покажите САМО РЕШЕНИЕ ЗАДАЧИ, за ранее спасибо.



Вы находитесь на странице вопроса "Решение задач с использованием файлов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.