Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

С помощью гениратора случайных чисел получить 12 чисел из диапозона от 0 до 8 и вывести на экран только числа больше 5, а также подсчитать кол-во

10-11 класс

выведенных чисел. Random

Lehaeliseew1 13 апр. 2015 г., 0:37:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
энига
13 апр. 2015 г., 2:47:11 (9 лет назад)

FPC IDE 2.6.0.

Только тут какой-то китайский рандом, и числа больше 8 только 6 выдает, но проверял алгоритм работает верно.

 

 var a:array[1..12] of integer; i,k:integer;


begin k:=0;
for i:=1 to 12 do
begin
a[i]:=random(8);
if a[i]>5 then inc(k);
end;

writeln('Kol-vo chisel bolsih za 5: ',k);
for i:=1 to 12 do
if a[i]>5 then writeln(a[i]);
readln;
end.

 

 

 

Ответить

Другие вопросы из категории

найти сумму квадратов натуральных чисел от 15 до 25. Создать массив а из десяти целых чисел принадлежащих промежутку [0;25) Вывести полученный массив на

экран. подсчитать k-количество элементов массива значение которых превышает 12 ПОМОГИТЕ СРОЧНО

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.



Вы находитесь на странице вопроса "С помощью гениратора случайных чисел получить 12 чисел из диапозона от 0 до 8 и вывести на экран только числа больше 5, а также подсчитать кол-во", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.