Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите с решением на паскале 10 класс

10-11 класс

Nelechka598 07 апр. 2015 г., 8:54:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Сахара5
07 апр. 2015 г., 11:49:40 (9 лет назад)

var b:array[1..999999] of integer;
n,i,min:integer;
begin
readln(n);
min:=1;
for i:=1 to n do begin
read(b[i]);
if b[min]>b[i] then min:=i;
end;
b[19]:=min;
for i:=1 to n do
write(b[i],' ');
end.





var a:array[1..999999] of integer;
max,n,i:integer;
begin
readln(n);
max:=1;
for i:=1 to n do begin
read(a[i]);
if a[max]<a[i] then max:=i;
end;
for i:=max to n-1 do
a[i]:=a[i+1];
for i:=1 to n-1 do
write(a[i],' ');
end.

+ 0 -
Elanina2014
07 апр. 2015 г., 12:32:50 (9 лет назад)

var b:array[1..999999] of integer;
n,i,min:integer;
begin
readln(n);
min:=1;
for i:=1 to n do begin
read(b[i]);
if b[min]>b[i] then min:=i;
end;
b[19]:=min;
for i:=1 to n do
write(b[i],' ');
end.





var a:array[1..999999] of integer;
max,n,i:integer;
begin
readln(n);
max:=1;
for i:=1 to n do begin
read(a[i]);
if a[max]<a[i] then max:=i;
end;
for i:=max to n-1 do
a[i]:=a[i+1];
for i:=1 to n-1 do
write(a[i],' ');
end.

Ответить

Другие вопросы из категории

написать программу на языке С#.Замечание. При решении данных задач

возможно использовать оператор switch или вложенные операторы if.

Читайте также

Паскаль, 10 класс. Прошу срочно помочь. Заранее спасибо!

Задача №1:
Используя операторы цикла, рассчитать сумму ряда для значений x=0.5; 0.55; 0.6; 0.65; 0.7; 0.75. Включать в сумму члены ряда, большие или равные значению eps=0.00001. Проверить правильность вычислений для контрольной точки x=0.5. Сравнить полученные значения со значениями, рассчитанными по точному аналитическому выражению.
2x3(куб)/3-2x5/15+2x7/35-...+(-1)k+1*2x(2k+1)/4k2-1+..., f(x)=(1+x2)arctgx-x, f(0.5)=0.07955.

Задача №2:
Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100. Найти и вывести на печать количество отрицательных чисел и среднее арифметическое значение всех чисел, расположенных после первого нулевого элемента.

Помогите с задачкой на паскале

Сформировать целочисленный массив из 15 элементов. Элементы массива ввести как случайные числа в диапазоне от –8 до 10. Отсортировать массив по возрастанию методом выбора и найти наибольшее значение разности между соседними элементами.

Помогите написать прогу на Паскале!Пожалуйста! Занятия в начальных классах отменяются в тех

случаях, когда температура воздуха не выше –25 градусов, а также при ветре не менее 7 м/с и температуре воздуха не выше –20 градусов. По утренней сводке погоды определить, пойдут ли дети в школу.

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Помогите решить задачу на паскале: в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на каждом из

10 этапов соревнований «Формула-1». После 10 этапа участник с порядковым номером 4 выбыл из соревнований. Изменить массив так, чтобы в нем не было результатов бывшего гонщика.



Вы находитесь на странице вопроса "помогите с решением на паскале 10 класс", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.