Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите, пожалуйста решить. Исполнитель кузнечик ползёт по клеткам бесконечной вертикальной клетчатой доски, переходя по одной из команд:вверх, вниз,

5-9 класс

вправо, влево - в соседнюю клетку в указанном направлении. Кузнечик выполнил следующюю программу: вправо вправо влево вверх вверх вниз влево вверх,в результате которой перешла из клетки а в клетку b. Укажите наименьшее возможное число команд в программе, переводящей КУЗНЕЧИКУ из начальной клетки а в конечную b.

Daria0209 19 июня 2015 г., 12:34:52 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
фукка
19 июня 2015 г., 13:07:08 (8 лет назад)

просто рисуешь и смотришь, ответ вроде: вверх, вверх, 2 команды

Ответить

Другие вопросы из категории

приведите примеры понятий:

А)тождественных;
Б)пересекающихся;
В)подчиняющихся и подчиненных;
Г)соподчиненных;

1.Переведи из двоичной системы счисления в десятичную.

а)111(2)=?(10) б) 1111(2)=?(10)

2.Переведи из десятичной системы в двоичную
а)19(10)=?(2)

Решите пожалуйста задачу!

Сообщение занимает 2 страницы и содержит 1\16 килобайта. На странице 256 символов. Сколько битов надо устройству для хранения одного символа?

Помогите найти ошибки - Паскаль.

Условие: Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами.

Не совсем то выводит
program proizvedenie;
var q,z,w,i,n,i1,i2:integer;
a:array[1..1000] of real;
amin,amax,pr:real;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
amin:=a[1];
for i:=1 to n do
begin
if a[i]<amin then
begin
amin:=a[i];
i1:=i;
end;
end;
amax:=a[1];
for i:=1 to n do
begin
if a[i] > amax then
amax:=a[i];
i2:=i;
end;
if i2>i1 then begin
q:=i1;
w:=i2;
end
else begin
q:=i2;
w:=i1;
end;
if (w-q)>1 then begin
pr:=1;
for z:=q to w do
pr:=pr*a[z];
end
else write (0);
close (input);
close (output);
end.


Читайте также

Исполнитель Черепашка ползет по клеткам бесконечной вертикальной клетчатой доски, переходя по одной из команд:

вверх, вниз, вправо, влево -

в соседнюю клетку в указанном направлении.



Черепашка выполнила следующую программу:

вправо вниз вправо вверх влево вверх вверх влево,



в результате которой перешла из клетки а в клетку b. Укажите наименьшее
возможное число команд в программе, переводящей Черепашку из начальной
клетки а в конечную клетку b.

1.

1)У исполнителя УТРОИТЕЛЬ две команды, которым присвоены номера:

1. вычти 1
2. умножь на 3
Первая из них уменьшает число на экране на 1, вторая – увеличивает его в три раза.Запишите порядок команд в программе получения из числа 3 числа 16, содержащей не более 5 команд, указывая лишь номера команд.(Например, программа 21211 это программа,которая преобразует число 1 в 4
умножь на 3
вычти 1
умножь на 3
вычти 1
вычти 1
2)Исполнитель робот ходит по клеткам бесконечной вертикальной клетчатой доски,переходя по одной из команд вверх,вниз,вправо,влево в соседнюю клетку в указанном направлении.
вправо
вверх
влево
влево
вниз
вниз
вправо
вправо
вправо
вниз
влево
Укажите наименьше взможное число команд в программе,переводящей Робота из той же начальной клетки

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Исполнитель Муравей перемещается по полю, разделённому на клетки.

Размер поля 8x8, строки нумеруются числами, столбцы обозначаются буквами.
Муравей может выполнять команды движения:
вверх N,
вниз N,
вправо N,
влево N, (где N – целое число от 1 до 7), перемещающие исполнителя на N
клеток вверх, вниз, вправо или влево соответственно.

повтори k раз
команда1 команда2 команда3
кц
означает, что последовательность команд команда1 команда2 команда3 повторится k раз.

Если на пути Муравья встречается кубик, то он перемещает его по ходу движения.

Пусть, например, кубик находится в клетке Б6.
Если Муравей выполнит команды вправо 1 вниз 3, то сам окажется в клетке Б5, а кубик в клетке Б4.

(четрёж во вложении)


Пусть Муравей и кубик расположены так, как указано на рисунке. Муравью был дан для исполнения следующий алгоритм:

повтори 4 раз

вниз 2 вправо 1 вверх 2

кц

В какой клетке окажется кубик после выполнения этого алгоритма?

(С подробным решением!)



Вы находитесь на странице вопроса "Помогите, пожалуйста решить. Исполнитель кузнечик ползёт по клеткам бесконечной вертикальной клетчатой доски, переходя по одной из команд:вверх, вниз,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.