Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать программу на

5-9 класс

массивах размерностью 5 и 10 элементов

Dimademan 02 июля 2013 г., 20:12:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ksy3993
02 июля 2013 г., 20:46:38 (10 лет назад)

var i,N:integer;

       Min:real;

      mas:array[0..100]of real;

beegin

write('введите N');

read(N);

 

{for i:=1 to N do begin

mas[i]:=random(50);write(mas[i],'  ');end;

 

или
for i:=1 to N do

read(mas[i]);

for i:=1 to N do

write(mas[i],'  ');}

 

min:=mas[0];

for i:=0 to N do 

if min<mas[i] then min:=mas[i];

 

writeln;

for i:=1 to N do begin

mas[i]:=mas[i]/min;write(mas[i]);end;

 

 

Ответить

Другие вопросы из категории

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести

на экран полученный массив и количе-ство замен. Протестировать программу на следующих исходных данных:
а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15
б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4
НА ПАСКАЛЕ

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.



Вы находитесь на странице вопроса "Написать программу, которая запрашивает массив из N элементов, а затем делает все элементы массива на минимальный элемент. Протестировать программу на", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.