Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

даны два числа возвести в квадрат отрицательные извлечь корень квадратный из положительных.

5-9 класс

сега2003 27 апр. 2015 г., 22:18:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Teteriya
27 апр. 2015 г., 23:18:03 (9 лет назад)

var x,y:real;
begin
read(x,y);
if x<0 then x:=x*x else x:=sqrt(x);
if y<0 then y:=y*y else y:=sqrt(y);
write(x,' ',y);
end.

Ответить

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1)Даны два целых числа A и B (A < B). Найти сумму квадратов всех целых чисел

от A до B включительно.
2)Даны натуральные числа от A до B(A<B). Найти произведение тех из них, которые делятся на 3 и не делятся на 4.
3)Ангелина узнав, что Боря занимается спортом, решила не отставать. Она каждый день делала от 3 до 5 упражнений на икры (вводится во время выполнения программы) и 5 упражнений на пресс. Сколько упражнений она сделала за 5, 10 и 13 дней. (количество упражнений на икры на каждый день вводится отдельно)


Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "даны два числа возвести в квадрат отрицательные извлечь корень квадратный из положительных.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.