Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите найти сколько звездочек будет в результате вызова F(5) пожалуйста,а то я запуталась совсем

10-11 класс

procedure F (n:integer);
begin
if n>1 then
begin
F(n div 2) ;
F(n-1)
end;
write ('*')
end;

Alishor23 20 нояб. 2013 г., 21:27:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Villia
21 нояб. 2013 г., 0:26:34 (10 лет назад)

Тринадцать:)

Ответить

Другие вопросы из категории

Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность

года на планетах (длина орбит/скорость). Результаты должны иметь вид:

Продолжительность года на планете <имя1> суток;

Продолжительность года на планете <имя2> суток;

Помогите составить программу в Pascal.

Сколько секунд потребуется модему , передающему информацию со скоростью 9600 бит\с,чтобы передать 70 страниц текста в 60 строк по 75 символов каждая при

условии, что каждый символ кодируется двумя байтами? Результат представьте целым числом. ( Служебной информацией пренебречь)

Даны натуральное число n, символы s1,...sn. , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя ,

будем называть словами. подсчитать количество букв a в последнем слове данной последовательности

В TPascal

Читайте также

Помогите плиз решить ничего не понимаю заранее спасибо

1.Сколько раз будет выполнена команда повторения в приведенных фрагментах при n=7:
1) for i :=n downto 4 do;
2)S:=S * i.
2. Определите, какой будет результат приведенного фрагмента: a:=100, n:=4:
for i:=1 to n do
a:=a - 2 * i.
Очень важно помогите.

Исполнитель Маляр стоит на клетчатом поле. Маляр может выполнять команды вправо, влево, вверх, вниз. При выполнении любой из этих команд он

перемещается на одну клетку соответственно вправо →,влево ←, вверх ↑, вниз ↓ по полю. Все клетки, через которые проходит Маляр (включая начальную и конечную), он закрашивает. Дана программа для этого исполнителя: НАЧАЛО ПОВТОРИТЬ 100 РАЗ вправо вправо влево влево вверх вправо вниз КОНЕЦ КОНЕЦ Сколько клеток будет закрашено в результате выполнения этой программы? Ответ обоснуйте.

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код

Народ, помогите, надо написать программу. Язык - на ваше усмотрение. Заранее спасибо, если кто поможет)

Даю чёткое ТЗ:
Шаг 1: У нас есть поле, в котором необходимо указать количество возможных событий (лучше это поле подписать рядом), после ввода туда нужного числа переходим к шагу 2.
Шаг 2: Далее идут поля под события и их процентную вероятность(тоже можно подписать рядом знаком"%"), то биш одно большое и одно маленькое поле на каждую строчку. Количество занятых строчек зависит от количества событий, введенных нами в шаге 1. Теперь вводим в большие поля названия событий (допустим: "дождь", "солнце", "ветер"), а в малые поля вводим их процентную вероятность (допустим "15", "73", "12"). Затем нажимаем кнопку снизу "результат" и под этой кнопкой появится выпавшее событие. При повторном нажатии данной кнопки, ситуация повторяется и нам снова выпадает какое-то событие.

Пример 1:
Количество событий: 3
ОК
Солнечно: 60 %
Ветренно: 25 %
Дождливо: 15 %
Результат
(тут будет написан результат)

Пример 2:
Количество событий: 2
ОК
Попадание: 60 %
Промах: 40%
Результат
(тут будет написан результат)



Вы находитесь на странице вопроса "помогите найти сколько звездочек будет в результате вызова F(5) пожалуйста,а то я запуталась совсем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.