Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны (вводятся) три

5-9 класс

числа. Первое уменьшили на 10, второе увеличили в 3 раза, а третье возвели в куб.
Составить программу, вычисляющую произведение полученных после преобразования чисел.

Рыжик97 28 нояб. 2015 г., 19:26:28 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Balles2000
28 нояб. 2015 г., 20:48:58 (8 лет назад)

var a,b,c,r:integer;
begin
read(a,b,c);
a-=10;
b*=3;
c*=sqr(c);
r:=a*b*c;
writeln(r);
end.

Ответить

Читайте также

1.Напишите программу расчёта площади прямоугольника,если известны его периметр и длина одной из сторон. Входные данные вводятся пользователем с экрана.

Вывод так же осуществляеться на экран.
2.Дана последовательность чисел а,b,c. Все отрицательные числа заменить на нули. Входные данные вводятся пользователем с экрана. Вывод так же осуществляется на экран.
Нужно составить вроде таблицу алгоритмов,помогите пожалуйста.
Я не прошу схемотично,хотя бы описание,где что должно быть написано,очень надо,помогите

Витя работает недалеко от одной из станций кольцевой линии Московского метро, а живет рядом с другой станцией той же линии. Требуется выяснить, мимо

какого наименьшего количества промежуточных станций необходимо проехать Вите по кольцу, чтобы добраться с работы домой.
Формат входных данных
Станции пронумерованы подряд натуральными числами 1, 2, 3, …, N (1-я станция – соседняя с N-й), N не превосходит 100.
Вводятся три числа: сначала N – общее количество станций кольцевой линии, а затем i и j – номера станции, на которой Витя садится, и станции, на которой он должен выйти. Числа i и j не совпадают. Все числа разделены пробелом.
Формат выходных данных
Требуется выдать минимальное количество промежуточных станций (не считая станции посадки и высадки), которые необходимо проехать Вите.
Примеры
Входные данные

Выходные данные

Комментарий

100 5 6

0

На кольцевой линии 100 станций; проехать с 5-й на 6-ю станцию Витя может напрямую, без промежуточных станций

10 1 9

1

На кольцевой линии 10 станций; проехать с 1-й на 9-ю станцию Витя может через одну промежуточную, ее номер 10

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

Задача «Справедливое распределение»

У Андрея было А грамм крупы, у Бориса – В
грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну
на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет
Андрею с Борисом.

Требуется написать программу, которая
определяет, как Андрей и Борис должны

поделить конфеты по справедливости.
Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или
из файла input.txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в
файл output.txt. В единственной

строке необходимо вывести два целых числа
— количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде

блок-схемы или на языке программирования Pascal)
1. С клавиатуры вводятся три целых числа. Определите количество положительных чисел в этом наборе.
2. С клавиатуры вводится целое число n. Вычислите сумму S=1+2+3+...+n.
3. С клавиатуры вводится целое число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса.
4. Вводится расстояние L в сантиметрах. Выясните, сколько в нём полных метров. Выведите это количество.



Вы находитесь на странице вопроса "Даны (вводятся) три", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.