Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Program ggl;

10-11 класс

var n, i, sum : integer;
a : array [1..1000] of integer;
begin readln (n);
sum := 0;
for i := 1 to n do begin
a[i] := random (100);
write (a[i], ' ');
sum := sum + a[i];
end;
writeln;
write (sum / n);
end.
ОБЪЯСНИТЬ ЧТО ВЫПОЛНЯЕТ КАЖДАЯ СТРОКА!!!

сергеймороз 30 нояб. 2016 г., 19:42:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Eenn103z
30 нояб. 2016 г., 22:20:43 (7 лет назад)

program ggl;

Ответить

Другие вопросы из категории

Записать последовательность операторов для решения задачи:

Дано описание:
type month = 1..12;
var d:28..31;
m:month;
Переменной d присвоить количество дней в месяце m (год считать не високосным)

Решите четвертую задачку в pascal
ребят, я не программист, пожалуйста помогите!

Тут надо что то поменять , чтобы выполнилось действие

Задание1
Вывести одномерный массив состоящий из 6 элементов . Выведите на экран 3 элемент умножав его на 10

Задание 2
Задан массив с 6 элементами, вывести все элементы массива умножив на 10

Читайте также

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

Какая тут ошибка, посмотрите, пожалуйста program znacheniya uglov; uses crt; var x: integer; begin writeln('wedite znachenie gradusnoi mery ugla');

read(x); if a=180 then writeln('razvernutyi') else writeln ('ne razvernutyi'); end.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

program vst; var

c:



Вы находитесь на странице вопроса "Program ggl;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.