Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сколько различных имен длиной не более 5 можно образовать в алгоритмическом языком, используя только следующие символы: а,b,1,5,#. Записать решение в виде

10-11 класс

линейного алгоритма в Pascal ABC. Заранее спасибо))) я на вас надеюсь

губарева 17 нояб. 2013 г., 11:11:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivankinaa
17 нояб. 2013 г., 13:34:55 (10 лет назад)

Наверное, так:) Сумма уоличества всех возможных имён длиной от 1 до 5 символов, но, право, циклом короче было бы ._.

Ответить

Другие вопросы из категории

Помогите сделать блок-схему:

Код программы:



в чем ошибка? сразу выделяет вторую строку и пишет ошибку declaration expected but identifier 's' found я уже весь интернет облазила, но не

понимаю, в чем суть ошибки

uses
SysUtils;
s,k,n:integer;
begin

writeln('vvedite n');
readln(n);
s:=0;
k:=1;
for i:=1 to n do
s:=i*(sqr*k);
i:=i+1;
writeln('s=',s:4:3);
{ TODO -oUser -cConsole Main : Insert code here }
end

Читайте также

Азбука Морзе позволяет кодировать символы для сообщений по радиосвязи, задавая комбинацию точек и тире. Сколько различных символов (цифр, букв, знаков

пунктуации и т.д.) можно закодировать, используя код азбуки Морзе длиной не менее пяти и не более шести сигналов (точек и тире)?

Помогите решить задачуна паскале.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Возможность отправлять закодированные сообщения во время Второй мировой войны была достаточно важной для союзников. Сообщения всегда отправлялись после их

кодирования при помощи известного пароля. Иметь фиксированный пароль было небезопасно, поэтому возникла необходимость часто изменять его. Однако следовало разработать механизм отправления нового пароля. У одного из математиков, работавших в криптографической команде, возникла умная идея - отправить пароль, скрытый в самом сообщении. Интересным моментом было то, что получателю сообщения достаточно было знать только размер пароля, а потом найти его в полученном тексте.

Пароль размера n можно найти поиском в тексте наиболее часто встречаемой подстроки из n символов. После нахождения пароля все подстроки совпадающие с ним, удаляются из текста. Теперь пароль можно использовать для расшифровки сообщения.

Однако Ваша задача будет упрощена. Вам достаточно написать программу, которая по заданному размеру пароля и закодированному сообщению найдет пароль в соответствии с описанным выше алгоритмом.

Рассмотрим пример, в котором размер пароля равен трем (n = 3), а текст сообщения имеет вид baababacb. Паролем будет aba, потому что размер этой подстроки 3, она появляется чаще всего во всем тексте (дважды), а остальные шесть различных подстрок появляются только один раз (baa, aab, bab, bac, acb).

Технические условия

Входные данные

Состоит из нескольких тестов. Каждый тест представляет собой одну строку, в которой находится длина пароля n (0 < n ≤ 10) и закодированное сообщение. Сообщение содержит только прописные буквы латинского алфавита, его длина не более 106 и не меньше n.

Выходные данные

Для каждого теста в отдельной строке следует вывести искомый пароль. Если существует несколько паролей, удовлетворяющих задаче, то вывести лексикографически наименьший.

Вам необходимо преобразовать множество старых программ для новой версии компилятора. Для этого необходимо заменить "->" на "." везде, кроме

комментариев. Комментарии в данном языке программирования начинаются с символов "//" и продолжаются до конца строки. Напишите программу, выполняющую такое преобразование. Входной файл содержит от 1 до 500 строк длиной не более 50 символов с ASCII-кодами от 32 до 127 – текст программы, которую нужно преобразовать. В выходной файл вывести преобразованный текст программы.

Пример ввода

Test* t = new Test(); t->a = 1; t->b = 2; t->go(); // a=1, b=2 -> a=2, b=3

Вывод для примера

Test* t = new Test(); t.a = 1; t.b = 2; t.go(); // a=1, b=2 -> a=2, b=3



Вы находитесь на странице вопроса "Сколько различных имен длиной не более 5 можно образовать в алгоритмическом языком, используя только следующие символы: а,b,1,5,#. Записать решение в виде", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.