Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Заполнить двумерный массив

5-9 класс

и вывести его на печать в виде


1 0 0 0 0


0 1 0 0 0


0 0 1 0 0


0 0 0 1 0


0 0 0 0 1


Подсказка;надо ввести условия для вывода
1,а в остальных случаях выводится 0

Dashashherbako1 23 февр. 2014 г., 1:35:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Olgatitova48
23 февр. 2014 г., 2:24:59 (10 лет назад)

program matrix1;
type
   matrix= array [1..5, 1..5] of integer;
var
   a : matrix;
   i, j: integer;
begin
   for i :=1 to 5 do begin
      for j :=1 to 5 do begin
         if i=j then a[i, j]:=1 else a[i, j]:=0;
         write (a[i,j], ' ');
        end;
        writeln (' ');
    end;
end.

Ответить

Другие вопросы из категории

Что такое фпс? И где его можно увидеть?
Составить программу в паскале и записать логику, без массива!

Три числа найти большее и наименьшее этих чисел и сравнить , большее с наименьшим и наименьшее с большим . Буду очень благодарна

решите 6 и 7 ))))))))
Помогите решить 2 задачи...

1) Вывести на экран квадрат наибольшего из 2 введенных чисел?
2) Вывести на экран корень наибольшего из 3 введенных чисел?

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Необходимо заполнить двумерный массив, как указано задании, в Pascal.

I - отвечает за номер строки.
J - отвечает за номер столбца.
Заполненные массивы должны выглядеть так:
a) при const n=3, m=3
1 2 1
2 3 2
1 2 1
в) при const n=5, m=5
1 2 3 2 1
2 1 2 1 2
3 2 1 2 3
2 1 2 1 2
1 2 3 2 1

Помогите, пожалуйста.

заполнить двумерный массив случайными числами. полученный массив вывести на экран. вычислить сумму элементов массива оканчивающихся на 4

Помогите,пожалуйста! очень надо!!!!

1. Заполнить двумерный массив размером ( 5, 11 ) целыми числами. Найти сумму положения элементов массива по главной диагонали. Вывести матрицу на экран.

2. Заполнить одномерный массив значением функции у=2 кв. корень из модуль х-2. Х=1,3,5...21. Вывести массив на экран в одну сторону. Найти сумму элементов массива.



Вы находитесь на странице вопроса "Заполнить двумерный массив", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.