Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Некоторая вещь стоит A рублей и B копеек. Было куплено N таких вещей. Запишите общую стоимость покупки в рублях и копейках в переменные C1 и С2. Значения

10-11 класс

переменных A и N не превосходят 30000, а значение переменной B не превосходит 100. Переменные С1 и С2 имеют тип longint. Другие переменные не использовать.

Промышленный 25 окт. 2014 г., 9:31:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergeitalkovn
25 окт. 2014 г., 12:29:02 (9 лет назад)

var C2, C1: longint;
    a, b, n: integer;
begin
     readln(a, b, n);
     b := b + a * 100;
     C1 := b * n;
     C2 := C1 mod 100;
     C1 := C1 div 100;
     writeln(C1, ',', C2);
end.

Вот так =)

+ 0 -
Nastya2002002
25 окт. 2014 г., 15:02:38 (9 лет назад)

Опять ЗФТШ

Ответить

Другие вопросы из категории

Какое значение будет иметь переменная d после выполнения операторов:

d:=0;
a:=1;
b:=1;
if a>0 then if b>0 then d:=1 else d:=2;

Вопрос№1

В программе, вычисляющей произведение отрицательных чисел из N введенных С клавиатуры ввод N
Р=1
Нц для i от 1 до N
Ввод а
Если ______________
То Р*а
Все Кц
Вывод Р

Необходимо вставить условие: 1)а 2)а>0 3)a=1 4)a<0

Вопрос№2
После выполнения фрагмента программы
х=5 z=7
Вывод ("Х=" , Х" = Z, Z+X)
На печать будет выведено:
1)Х=Х Х= ZZ+Х
2)Х=5 Х=7 Z+Х
3)Х=5 Х=712
4)Х=5 Х=7 Z+Х=12

Одна кодировочная таблица содержит 1024 символа. Для кодирования символа из второй таблицы требуется на 1 бит меньше, чем для кодирования символа из

первой таблицы. Определите, сколько символов включено во вторую кодировочную таблицу

Для приближенного перевода дат с мусульманского календаря на григорианский можно пользоваться следующей формулой: Г = М + 622 - (М/33) где Г - год

григорианского календаря, М - год мусульманского календаря.Какой год был по мусульманскому календарю в 1985 году (год начала изучения информатики в школах России)?
1) 1363-1364; 2) 1405-1406; 3) 2005-2006; 4) 2045-2046.

Читайте также

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.

помогите пожалуйста нужна программа Паскаль вот задача (При каждом переходе через волшебный мост мужик, имеющий b рублей, удваивает эту сумму за счет

капитала черта (а рублей), стерегущего этот мост, после чего он должен уплатить черту дань в размере с рублей. Процесс этот продолжается до полного разорения одного из участников.Сколько будет совершено переходов моста?). вот блок схема пожалуйста сроочноо



Вы находитесь на странице вопроса "Некоторая вещь стоит A рублей и B копеек. Было куплено N таких вещей. Запишите общую стоимость покупки в рублях и копейках в переменные C1 и С2. Значения", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.